Bug 844322 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'remove_name' accesses on the directory registry.x86_64.bin.tmpMEHBIW.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'remove_name' acc...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f0b98feee3b3be80135f08a37bb...
:
: 844924 844925 847058 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 05:50 EDT by mamii
Modified: 2012-08-10 02:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 11:34:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mamii 2012-07-30 05:50:43 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-1.fc17.x86_64
time:           Mon 30 Jul 2012 10:50:24 AM CET

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'remove_name' accesses on the directory registry.x86_64.bin.tmpMEHBIW.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed remove_name access on the registry.x86_64.bin.tmpMEHBIW directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:admin_home_t:s0
:Target Objects                registry.x86_64.bin.tmpMEHBIW [ dir ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-3.4.3-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-1.fc17.x86_64 #1 SMP
:                              Thu Jul 26 21:48:14 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 30 Jul 2012 10:49:24 AM CET
:Last Seen                     Mon 30 Jul 2012 10:49:24 AM CET
:Local ID                      89c8dc6f-df90-415d-81fa-0c3c5552682a
:
:Raw Audit Messages
:type=AVC msg=audit(1343641764.400:125): avc:  denied  { remove_name } for  pid=7729 comm="totem-video-thu" name="registry.x86_64.bin.tmpMEHBIW" dev="dm-2" ino=1046679 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1343641764.400:125): avc:  denied  { rename } for  pid=7729 comm="totem-video-thu" name="registry.x86_64.bin.tmpMEHBIW" dev="dm-2" ino=1046679 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1343641764.400:125): arch=x86_64 syscall=rename success=yes exit=0 a0=1e404e0 a1=1bb3ae0 a2=1d3c780 a3=7fffafbb2fc0 items=0 ppid=7270 pid=7729 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=2 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,admin_home_t,dir,remove_name
:
:audit2allow
:
:#============= thumb_t ==============
:allow thumb_t admin_home_t:dir remove_name;
:allow thumb_t admin_home_t:file rename;
:
:audit2allow -R
:
:#============= thumb_t ==============
:allow thumb_t admin_home_t:dir remove_name;
:allow thumb_t admin_home_t:file rename;
:
Comment 1 Daniel Walsh 2012-07-31 11:34:28 EDT
You really should not be running nautilus as root, as this shows you have processes running as root based on the content of some CD or USB Stick.
Comment 2 Miroslav Grepl 2012-08-01 11:26:56 EDT
*** Bug 844924 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-08-01 11:27:07 EDT
*** Bug 844925 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-08-10 02:07:08 EDT
*** Bug 847058 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.