Bug 844925 - SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'write' accesses on the file /drm mm object (deleted).
SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'wr...
Status: CLOSED DUPLICATE of bug 844322
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:10a22ab99c004c777423d6860fe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 05:37 EDT by mamii
Modified: 2012-08-01 11:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 11:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mamii 2012-08-01 05:37:37 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           Wed 01 Aug 2012 10:37:19 AM CET

description:
:SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'write' accesses on the file /drm mm object (deleted).
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/drm mm object (deleted) default label should be etc_runtime_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /drm mm object (deleted)
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that gst-plugin-scanner should be allowed write access on the drm mm object (deleted) file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gst-plugin-scan /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:tmpfs_t:s0
:Target Objects                /drm mm object (deleted) [ file ]
:Source                        gst-plugin-scan
:Source Path                   /usr/libexec/gstreamer-0.10/gst-plugin-scanner
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gstreamer-0.10.36-1.fc17.x86_64
:                              gstreamer-0.10.36-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-1.fc17.x86_64 #1 SMP
:                              Thu Jul 26 21:48:14 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 30 Jul 2012 10:49:21 AM CET
:Last Seen                     Mon 30 Jul 2012 10:49:21 AM CET
:Local ID                      5004c35c-cf76-48f0-b57e-18d3c0437e0a
:
:Raw Audit Messages
:type=AVC msg=audit(1343641761.116:122): avc:  denied  { write } for  pid=7730 comm="gst-plugin-scan" path=2F64726D206D6D206F626A656374202864656C6574656429 dev="tmpfs" ino=140096 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmpfs_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1343641761.116:122): arch=x86_64 syscall=ioctl success=yes exit=0 a0=7 a1=c020645e a2=7fff16335e70 a3=38 items=0 ppid=7729 pid=7730 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=2 comm=gst-plugin-scan exe=/usr/libexec/gstreamer-0.10/gst-plugin-scanner subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gst-plugin-scan,thumb_t,tmpfs_t,file,write
:
:audit2allow
:
:#============= thumb_t ==============
:allow thumb_t tmpfs_t:file write;
:
:audit2allow -R
:
:#============= thumb_t ==============
:allow thumb_t tmpfs_t:file write;
:
Comment 1 Miroslav Grepl 2012-08-01 11:27:07 EDT

*** This bug has been marked as a duplicate of bug 844322 ***

Note You need to log in before you can comment on or make changes to this bug.