Bug 845040 - selection is reported incorrectly in file chooser button
selection is reported incorrectly in file chooser button
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
: 852089 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 11:00 EDT by Piruthiviraj Natarajan
Modified: 2013-05-27 21:03 EDT (History)
6 users (show)

See Also:
Fixed In Version: gtk2-2.24.18-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 21:03:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piruthiviraj Natarajan 2012-08-01 11:00:52 EDT
Description of problem:
When you add a torrent you should be able to download it to a user specified location on your hard disk. But in Deluge 1.3.5 when you select  file->add a torrent->options->downloadlocation-> other(scroll down to the lowest in the menu).  What ever location you set in "other" is not recognized by the application and it sets itself to default /home/user/Downloads.

So basically the "other" option is not working.

Version-Release number of selected component (if applicable):

1.3.5
How reproducible:

Every time



Additional info:

but except 'other' in the menu all other default Download locations shown in the menu are working.
Comment 1 Piruthiviraj Natarajan 2012-08-16 23:39:52 EDT
No response after more than 2 weeks?
Comment 2 Artyom Kunyov 2012-09-09 00:50:29 EDT
*** Bug 852089 has been marked as a duplicate of this bug. ***
Comment 3 Piruthiviraj Natarajan 2012-10-04 10:10:46 EDT
Its been more than 6 weeks. No reply. I didn't know that bugzilla was a joke.
Comment 4 Calum 2012-10-06 06:33:29 EDT
It is best to report upstream directly to us, however this has been reported already: dev.deluge-torrent.org/ticket/2169
Comment 5 Piruthiviraj Natarajan 2012-10-06 07:06:22 EDT
Thanks for the answer and concern, much appreciated!
Comment 6 Piruthiviraj Natarajan 2013-02-18 10:01:09 EST
@rahul
Its still not fixed.

Did you even check?
Comment 7 Rahul Sundaram 2013-02-18 14:05:57 EST
Perhaps you didn't understand the status.  CLOSED UPSTREAM  =  it is being tracked upstream.  It doesn't mean it is fixed downstream.
Comment 8 Rahul Sundaram 2013-02-18 14:18:14 EST
On second thought, this bug isn't really in deluge either but in GTK2.  I am going to reassign and request a GTK2 update

GTK2 maintainers - the issue is addressed by the following patch

http://git.gnome.org/browse/gtk+/commit/?id=81df0059

Upstream discussion at

https://bugzilla.gnome.org/show_bug.cgi?id=691040

2.24.15 seems to address this but cherry picking patches is ok as well.  This affects a number of packages using GTK.  Thanks!
Comment 9 Piruthiviraj Natarajan 2013-05-17 05:47:01 EDT
Looks like its solved in Rawhide now 2.24.18.
Comment 10 Fedora Update System 2013-05-25 20:07:53 EDT
gtk2-2.24.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gtk2-2.24.18-1.fc18
Comment 11 Fedora Update System 2013-05-26 20:32:32 EDT
Package gtk2-2.24.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk2-2.24.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9336/gtk2-2.24.18-1.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-05-27 21:03:08 EDT
gtk2-2.24.18-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.