Bug 845160 - Update the appendix example
Update the appendix example
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Misha H. Ali
:
: 852710 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 23:24 EDT by Misha H. Ali
Modified: 2012-11-08 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-08-01 23:24:37 EDT
Update the appendix examples with suggested changes by SME
Comment 2 Misha H. Ali 2012-08-02 00:29:13 EDT
Changes made, will be set to ON_QA once the change is staged.
Comment 4 Radim Hatlapatka 2012-10-11 07:36:15 EDT
Proxy Server - configuration example
1) there is an typo error at the start, the "<" shouldn't be there
2) it is a good practise to put the module specific part into <IfModule> element =>

<IfModule manager_module>
Listen 127.0.0.1:6666
<VirtualHost 127.0.0.1:6666>

    <Directory />
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Directory>

    KeepAliveTimeout 60
    MaxKeepAliveRequests 0

    ManagerBalancerName mycluster
    ServerAdvertise On
    AdvertiseFrequency 5
    EnableMCPMReceive On

<Location /mod_cluster-manager>
    SetHandler mod_cluster-manager
    Order deny,allow
    Deny from all
    Allow from 127.0.0.1
</Location>

</VirtualHost>

</IfModule>
Comment 5 Radim Hatlapatka 2012-10-11 07:41:37 EDT
Additionally in EWS 2.0 documentation should be example with using EWS tomcats and not EAP

=> in subsection Use the Default Configuration
Should be setting for tomcat, which is described here: http://docs.jboss.org/mod_cluster/1.2.0/html_single/#d0e399
Comment 6 Radim Hatlapatka 2012-10-11 07:45:14 EDT
And the part in subsection: Example iptables Firewall Rules:

This part of firewall configuration is irrelevant because Tomcats in EWS don't support clustering and session replication => there is no inter-node communication:

/sbin/iptables -I INPUT 9 -p udp -s 192.168.1.0/24 -j ACCEPT -m comment --comment "cluster subnet for inter-node communication"
/sbin/iptables -I INPUT 10 -p tcp -s 192.168.1.0/24 -j ACCEPT -m comment --comment "cluster subnet for inter-node communication"
/etc/init.d/iptables save
Comment 7 Radim Hatlapatka 2012-10-11 09:36:56 EDT
*** Bug 852710 has been marked as a duplicate of this bug. ***
Comment 8 Misha H. Ali 2012-10-12 00:03:57 EDT
1. comment#4 feedback: Removed unnecessary < and updated example.

2. comment#5 feedback: updated content.

3. comment#6 feedback: removed two lines identified as not relevant.

This bug will be set to ON_QA once the changes appear on the stage.
Comment 10 Misha H. Ali 2012-11-08 17:11:20 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.