Bug 845213 - [FEAT] Need O_DIRECT support in translators
[FEAT] Need O_DIRECT support in translators
Status: CLOSED DUPLICATE of bug 857673
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks: 850503 850666 852367 856156
  Show dependency treegraph
 
Reported: 2012-08-02 05:45 EDT by Vidya Sakar
Modified: 2013-12-08 20:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 856156 (view as bug list)
Environment:
Last Closed: 2012-10-09 22:59:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-02 05:45:20 EDT
Description of problem:

Need O_DIRECT support in translators to avoid page caching.
Comment 1 Amar Tumballi 2012-09-04 00:01:44 EDT
O_DIRECT support is present in all of the performance translators. Only enhancement required to support VM hosting better is that in write-behind queueing up writes of O_DIRECT flag too.
Comment 2 shishir gowda 2012-10-09 22:59:20 EDT

*** This bug has been marked as a duplicate of bug 857673 ***
Comment 3 Vijay Bellur 2012-11-28 06:37:16 EST
CHANGE: http://review.gluster.org/4206 (protocol/client: add an option to filter O_DIRECT flag in open) merged in master by Vijay Bellur (vbellur@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.