This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 850503 - Improvements to Performance translators in RHS 2.1
Improvements to Performance translators in RHS 2.1
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
unspecified
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
SATHEESARAN
: FutureFeature
Depends On: GLUSTER-3711 765785 845213 846240 856156 857673
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 13:00 EDT by Vidya Sakar
Modified: 2013-09-23 18:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa4-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-21 13:00:38 EDT
Tracker bug for all the improvements planned around performance translators for RHS 2.1.
Comment 2 Amar Tumballi 2012-10-11 05:47:14 EDT
846240 - will be addressed post 2.1

GLUSTER-3711 - Done and verified
765785 - Done and verified http://review.gluster.com/771

856156 - 845213 - done with  http://review.gluster.org/3947
Comment 3 Amar Tumballi 2012-12-06 00:15:14 EST
Bug 765443 - (GLUSTER-3711) glusterd log shows "file sizes are different" after rebalance is performed Status:	VERIFIED

Bug 765785 - Enhance 'readdirp' fop to send xattrs and inodes in _cbk() Status:	VERIFIED 

Bug 856156 - [FEAT] Need O_DIRECT support in translators Status:	MODIFIED

Bug 857673 - write-behind: implement causal ordering of requests for better VM performance Status:	MODIFIED
Comment 5 SATHEESARAN 2013-08-13 03:30:05 EDT
Verified the following bugs with glusterfs-3.4.0.18rhs-1

Bug 765443 - Rebalance happened successfully with write-behind set to ON, and there are no error like 'files are different size'

Bug 765785 - readdirp fetches xattrs

Bug 856156 - Already got closed

Bug 857673 - performance.strict-write-ordering option is avaiable, which could be turned on/off at will, to implement casual ordering

Moving this bug to VERIFIED
Comment 6 Scott Haines 2013-09-23 18:29:54 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.