Bug 845222 - Cursor unusable after vdagent gets killed
Cursor unusable after vdagent gets killed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-vdagent-win (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Arnon Gilboa
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 06:45 EDT by Tomas Jamrisko
Modified: 2013-04-10 11:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: vdagent-win-0.1-12
Doc Type: Bug Fix
Doc Text:
Killing just the vdagent and not vdservice on a windows 7 guest resulted in the cursor being unusable.An update has been made to ensure that the vdagent starts correctly and these problems will no longer occur. As a result the guest's mouse will now respond correctly to user input.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:19:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdservice: restart vdagent if killed manually (1.45 KB, patch)
2012-09-16 07:04 EDT, Arnon Gilboa
no flags Details | Diff

  None (edit)
Description Tomas Jamrisko 2012-08-02 06:45:19 EDT
Description of problem:

Killing just vdagent and not vdservice on a windows 7 guest results in cursor being unusable.

Version-Release number of selected component (if applicable):
vdagent-win-0.1-11

How reproducible:
always 

Steps to Reproduce:
1. Make sure both vdservice and vdagent are running on your VM
2. Kill only vdagent, keep vdservice running 
  
Actual results:
Cursor is pretty much unusable (it only changes it's appearance, does not respond to clicks)

Expected results:
Service should either either start agent again or it should terminate itself (cursor falls back in that case)
Comment 1 Christophe Fergeau 2012-08-06 05:29:47 EDT
Most likely a duplicate of bug #839564. See also http://thread.gmane.org/gmane.comp.emulators.spice.devel/10410
Comment 2 Arnon Gilboa 2012-09-16 07:04:32 EDT
Created attachment 613396 [details]
vdservice: restart vdagent if killed manually
Comment 7 errata-xmlrpc 2012-12-04 13:19:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1502.html

Note You need to log in before you can comment on or make changes to this bug.