Bug 845236 - Installer could ask for elevated privileges (UAC) (because of usbclerk)
Installer could ask for elevated privileges (UAC) (because of usbclerk)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: usb-clerk-win (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Arnon Gilboa
Desktop QE
spice
:
Depends On: 984137
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 07:58 EDT by Tomas Jamrisko
Modified: 2016-02-10 15:21 EST (History)
11 users (show)

See Also:
Fixed In Version: mingw-usbclerk-0.0.1.1-2.el6_4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 11:23:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2012-08-02 07:58:35 EDT
Description of problem:

Installing virt-viewer under regular user usually informs user about usbclerk not being installed, because of insufficient access rights. 

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.3-9.el6

How reproducible:
Always

Steps to Reproduce:
1. Start virt-viewer installer
2. Proceed
  
Actual results:
Early on in the installation the user gets a notification about usbclerk not being installed

Expected results:

Would be great if the installer tried to elevate priviliges when it starts
Comment 1 Marc-Andre Lureau 2012-08-02 08:08:12 EDT
The installer is UAC. In theory, the .cab installation should be silent. I wasn't aware of this dialog it has been added recently, I suppose it will be shown only once during first installation (do we want that dialog at every upgrade?).

I am not sure how we can ask the user to elevate privileges during installation, and that would perhaps also be annoying for users who might get confused and think they can't do the installation. Even if the user can't give admin privileges, the installation should still complete anyway.
Comment 2 Tomas Jamrisko 2012-08-02 09:58:13 EDT
Well, so it's reasonable to assume, that the installation can no longer be completely silent (as usb sharing from windows clients seems to be a rather important new feature).

Anyway, it seems that virt-viewer installer is using NSIS, isn't it possible to make usbclerk a post-install option and use UAC plugin to gain admin access?
Comment 3 Marc-Andre Lureau 2012-08-02 10:12:12 EDT
(In reply to comment #2)
> Well, so it's reasonable to assume, that the installation can no longer be
> completely silent (as usb sharing from windows clients seems to be a rather
> important new feature).

Until now, it was silently not installing USB clerk if run as regular user. I don't think the dialog is the best way to tell the user that information. The question last week was rather if we should ship the USB clerk installer seperately. (I was away last week and didn't participate to the discussion that lead to the current behaviour)

> Anyway, it seems that virt-viewer installer is using NSIS, isn't it possible
> to make usbclerk a post-install option and use UAC plugin to gain admin
> access?

As long as the installation can be performed silently by regular user.

If you want my honest opinion, I think the cab is really *the wrong way* of doing all of this, and we should go with a seperate _visible_ installer. It seems quite easy to me to replace the current cab mechanism, by an activex version check giving a link to the installer directly in the page. Imho, the situation that happens today is that none of the Spice developper really can make this change happen, and none of the rhevm developper seem to care enough either to make this change happen or even participate to the discussion to improve that situation. The cab is today ~16mb I listed several times *all* the issues the cab system have, and this bugs shows again how limited we are with the current cab approach. That cab should just go away, honestly.
Comment 4 Uri Lublin 2012-08-08 07:05:30 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > Well, so it's reasonable to assume, that the installation can no longer be
> > completely silent (as usb sharing from windows clients seems to be a rather
> > important new feature).
> 
> Until now, it was silently not installing USB clerk if run as regular user.
> I don't think the dialog is the best way to tell the user that information.

Without usbclerk, usbredir fails. We wanted users to know that.
You do have a good point about the silent install being broken by this.
Comment 5 Marc-Andre Lureau 2012-08-08 07:24:51 EDT
(In reply to comment #4)
> Without usbclerk, usbredir fails. We wanted users to know that.
> You do have a good point about the silent install being broken by this.

It would be more reliable to have a hint during the execution of the client, for example, if the usbclerk is not running.
Comment 7 Marc-Andre Lureau 2013-07-15 09:04:35 EDT
mingw-virt-viewer will no longer ship the activex, moving to appropriate component.

(mingw-virt-viewer will be provided as admin MSI which makes this bug obsolete there)
Comment 8 Marc-Andre Lureau 2013-07-15 09:09:11 EDT
I realize it's not so much an ActiveX/CAB bug.. so I think we should move this bug to depend on 984137 instead (USB clerk MSI)
Comment 9 David Blechter 2013-07-16 11:23:12 EDT
close as WONTFIX.

The usb installation problem will be addressed in machine level usb-clerk MSI installation (984137). And the usb-clerk installation will be removed from the user level installation, so the this bug is irrelevant for 3.3.

Note You need to log in before you can comment on or make changes to this bug.