Bug 984137 - Provide MSI machine installer for usbclerk
Provide MSI machine installer for usbclerk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: usb-clerk-win (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks: 845236 885200 894284
  Show dependency treegraph
 
Reported: 2013-07-12 19:04 EDT by Marc-Andre Lureau
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: spice-client-msi-3.3-6
Doc Type: Enhancement
Doc Text:
Feature: Provide usbclerk MSI installer Reason: The current usbclerk installer is hidden in CAB installer, and not admin friendly. It doesn't follow Windows Installer practices. It is hard to maintain. Result (if any): Provide a admin friendly windows installer, more robust thanks to Windows Installer services.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:47:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc-Andre Lureau 2013-07-12 19:04:59 EDT
spin of from 885200

Mass windows deployment of usbclerk via msi

MSI installers are a great way for AD Administrators to deploy items like the SPICE/Desktop Viewer application to all the relevant users/systems en mass

+MSI is the recommended practice using Windows Installer mechanism.
Comment 3 Marc-Andre Lureau 2013-07-24 10:01:52 EDT
there are 2 seperate installers, one for x86 and another for x64
Comment 7 Marc-Andre Lureau 2013-07-25 13:44:50 EDT
We need to consider the version scheme for future releases in order to perform upgrade. 0.0.1.1 -> 0.1.buildid
Comment 10 Marc-Andre Lureau 2013-11-11 09:51:30 EST
though the current MSI installs fine, upgrade is currently broken. This can be verified by taking candidate build version. After upgrade, some files will be missing such as remote-viewer.exe!

I am moving back this bug to assign, I think I know what's going on, and I will submit a new build asap.,
Comment 11 Charlie 2013-12-05 20:41:14 EST
Does this need doc text?

Thanks
Comment 12 Vaclav Ehrlich 2013-12-18 10:45:10 EST
I've tried update from 3.3.5. to 3.3.6. and USB was not working. If I've tried clean install of both version USB was fine (in both cases).

Is there recommended version of usbclerk to upgrade ? Or this should also work ?

Guest WinXP32
Client Win7 32
connection: Native client
virt-viewer 0.5.615.el6_5
Comment 13 Marc-Andre Lureau 2013-12-18 19:36:11 EST
(In reply to Vaclav Ehrlich from comment #12)
> I've tried update from 3.3.5. to 3.3.6. and USB was not working. If I've
> tried clean install of both version USB was fine (in both cases).
> 
> Is there recommended version of usbclerk to upgrade ? Or this should also
> work ?

Yes, you need to uninstall old usbclerk, and then install MSI.

(the MSI will attempt to do that, but may fail if it doesn't find old install)
Comment 14 Vaclav Ehrlich 2013-12-19 10:15:59 EST
Sorry, founded error was in WinXP and it is already reported.
I've tested it in Win7 and installation and upgrade from previous version seems to be working.
Comment 19 errata-xmlrpc 2014-01-21 09:47:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0059.html

Note You need to log in before you can comment on or make changes to this bug.