Bug 845277 - JBoss ON dashboard shows messed metric graph on IE 8/9
JBoss ON dashboard shows messed metric graph on IE 8/9
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.2
All Windows
urgent Severity urgent
: CR03
: JON 3.1.2
Assigned To: Mike Thompson
Mike Foley
:
Depends On: 852837
Blocks: 880594
  Show dependency treegraph
 
Reported: 2012-08-02 10:29 EDT by Amana
Modified: 2013-09-11 07:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852837 (view as bug list)
Environment:
Last Closed: 2013-09-11 07:03:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot - Broken graph on dashboard (59.58 KB, image/png)
2012-08-06 11:37 EDT, Larry O'Leary
no flags Details
Screenshot - Working graph on Monitoring > Graphs view (9.16 KB, image/png)
2012-08-06 11:39 EDT, Larry O'Leary
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 177443 None None None 2012-08-06 12:49:15 EDT

  None (edit)
Description Amana 2012-08-02 10:29:54 EDT
The Metric Graphs in JBoss ON dashboard is messed/ broken on IE 8/9. It is just displaying the graph numbers. Steps to reproduce:

1. create a new dashboard (click on Dashboard menu -> New Dashboard)
2. select Resource Metric Graph or Resource Group Metric in the Add Portlet combo
3. click on the Edit icon placed in the right top corner of the new portlet
4. choose some resource (i.e Datasource) in the Resource combo (i.e. DefaultDS)
5. choose any of the available options in the Metric combo (i.e. Available Connection Count)
6. click on save button

Actual results:
The metric graphs will be broken.

Expected results:
The graphs should be displayed correctly like for firefox.

Additional info:
On Firefox, it works well.
Comment 3 Larry O'Leary 2012-08-06 11:37:54 EDT
Created attachment 602534 [details]
Screenshot - Broken graph on dashboard

Screen-shot showing how the broken graph looks on the Dashboard. The graph points appear to be missing and the axis labels are misplaced.
Comment 4 Larry O'Leary 2012-08-06 11:39:22 EDT
Created attachment 602535 [details]
Screenshot - Working graph on Monitoring > Graphs view

Screen-shot showing the same graph working on the resource's Monitoring > Graphs view tab.
Comment 5 Larry O'Leary 2012-08-06 12:03:57 EDT
Same issue affects both IE 8 and IE 9. Reproduced with the following versions:
    Version: 9.0.8112.16421
    Version: 8.0.6001.18702
Comment 7 Charles Crouch 2012-08-06 13:01:24 EDT
mtho11_lunch: can you provide some initial comments on https://bugzilla.redhat.com/show_bug.cgi?id=845277
Comment 8 Jirka Kremser 2012-08-13 12:22:17 EDT
The charts use the gflot library, which internally uses the <CANVAS> element (not supported in IE8/9). Fortunately, there are some workarounds. The most promising are excanvas http://code.google.com/p/explorercanvas/ and GWTCanvas from GWT Incubator (http://code.google.com/p/google-web-toolkit-incubator/wiki/GWTCanvas). The former one is more mature.

Currently we use gflot in version 1.0.0. There is 2.4.2 version present in Maven Central. It seems like the newest version has built-in support for excanvas, but the API has been slightly modified (just some refactoring, nothing serious). So I am trying to upgrade the version of gflot,
Comment 9 Jirka Kremser 2012-08-15 13:51:34 EDT
master
time:    Wed Aug 15 19:42:24 2012 +0200
commit:  5d243b30f5315f18329f6f4fa9db22ae47eb32bd
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 845277 - JBoss ON dashboard shows messed metric graph on IE 8/9] Version of gflot upgraded to 2.4.2 (it contains the excanvas library for IE8/9 support of HTML canvas el.), version of sparkline upgraded to 2.0, version of jquery upgraded to 1.7.2
Comment 10 Jirka Kremser 2012-08-15 14:17:14 EDT
http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=5d243b3
http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=8000e71

master
time:    Wed Aug 15 20:13:14 2012 +0200
commit:  8000e712dd98fd8ee8e1ff52940e15b07f11e782
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 845277] - quick fix: removed the doctype declaration and removed overcasting to int
Comment 11 Mike Thompson 2012-08-15 15:09:25 EDT
I have verified the fix for IE8 and reviewed solution.
Comment 12 Larry O'Leary 2012-08-29 13:59:01 EDT
Moving back to ON_DEV as this has not yet been committed to JON 3.1.2 and will need to wait for the release/jon3.1.x branch to be open for 3.1.2 commits. Once open, the master commit should be cherry-picked.
Comment 13 Jirka Kremser 2012-11-02 11:16:31 EDT
http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=b9d4a5f99

branch:  release/jon3.1.x
time:    Fri Nov 2 15:50:33 2012 +0100
commit:  b9d4a5f99ebc403ad169f7da26a04a6877c95dfa
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 845277 - JBoss ON dashboard shows messed metric graph on IE 8/9] Version of gflot upgraded to 2.4.2 (it contains the excanvas library for IE8/9 support of HTML canvas el.), version of sparkline upgraded to 2.0, version of jquery upgraded to 1.7.2; quick fix: removed the doctype declaration and removed overcasting to int (cherry-picked and merged into one commit from 5d243b3 and 8000e71)


changing status to MODIFIED
Comment 14 Simeon Pinder 2012-11-15 00:00:25 EST
Moving this to ON_QA as available for testing in https://brewweb.devel.redhat.com//buildinfo?buildID=243389.
Comment 16 Sunil Kondkar 2013-01-10 09:19:45 EST
Verified on JON 3.1.2 CR2 build.

Verified on IE9 and IE8 (IE 9.0.8112.16421 and IE 8.0.6001.18702)

Followed the steps and verified that metric graphs for resources selected in 'Resource Metric Graph' and 'Resource Group Metric' portlets are displayed correctly.

Also verified that the icon in the Resource Metric Graph portlet (to view the live graph of current values) displays correct graph.
Comment 17 Larry O'Leary 2013-01-14 10:30:01 EST
Looks like the fix for this issue has introduced a very bad regression. Bug 894319 identifies the new bug that this fix introduced. Based on the deprecated status of IE8 and the continued effort necessary to add support for IE9, we may end up backing this fix out and re-targeting to 3.2.
Comment 18 Larry O'Leary 2013-01-14 18:20:18 EST
As per bug triage meeting today, this fix needs to be backed out due to the fact that it breaks sparkline graphs as described in bug 864319.

Re-assigned to Mike Thompson and status updated to ASSIGNED. This is blocking for the 3.1.2.CR3 build.
Comment 19 Mike Thompson 2013-01-15 14:20:34 EST
Fixed with BZ 894319. No need to back out as fix is true to fix BZ 894319 and it now no longer breaks this BZ so we can leave it in. In fact, it was reverted earlier and is now put back in with release/jon3.1.x commit: 
http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=8c1226a9b

Needs to be retested.
Comment 20 Sunil Kondkar 2013-01-17 06:40:13 EST
Verified on JON 3.1.2 CR3 build.

Followed the steps and verified that the portlets display correct metric graphs. Verified on IE9 and IE8 (IE 9.0.8112.16421 and IE 8.0.6001.18702)

Note You need to log in before you can comment on or make changes to this bug.