Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 880594 - Content sources page view needs use of scrollbar on Firefox 10.0.2
Summary: Content sources page view needs use of scrollbar on Firefox 10.0.2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.1.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: JON 3.1.2
Assignee: Mike Thompson
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On: 845277
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-27 12:02 UTC by Sunil Kondkar
Modified: 2013-09-11 10:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-11 10:58:56 UTC
Type: Bug


Attachments (Terms of Use)
Page view - JON 3.1.2 ER2 build (99.18 KB, image/png)
2012-11-27 12:04 UTC, Sunil Kondkar
no flags Details
Page view - JON 3.1.1 GA build (123.77 KB, image/png)
2012-11-27 12:09 UTC, Sunil Kondkar
no flags Details
Pageview_Repositories (87.52 KB, image/png)
2012-11-29 13:38 UTC, Sunil Kondkar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 845277 0 urgent CLOSED JBoss ON dashboard shows messed metric graph on IE 8/9 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 883946 0 unspecified CLOSED Graph layout on monitoring page is changed. Graph is now closed in narrow div. 2021-02-22 00:41:40 UTC

Internal Links: 845277 883946

Description Sunil Kondkar 2012-11-27 12:02:50 UTC
Description of problem:

When navigated to Administration->Content->Content Sources, the page displays the content source "JBoss CP Patch Feed" with scrollbar.
Clicking on the link "JBoss CP Patch Feed" displays the page again with scrollbar. Please find attached the screenshot as viewed on JON 3.1.2 ER2 build.

Version-Release number of selected component (if applicable):
Version: 3.1.2.ER2
Build Number: 504cef5:b78316e

Browser Version: Firefox 10.0.2

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Administration->Content->Content Sources
2. Click on the link "JBoss CP Patch Feed"
3. View the page. We need to use the scrollbar to view the page.

Actual results:
Content sources page view changed - The page view needs use of scrollbar on Firefox 10.0.2

Expected results:
Full page view without scrollbar.

Additional info:
Earlier it was a full page view without scrollbar. For comparison, I am attaching a screenshot as viewed on JON 3.1.1 GA build with same browser version FF 10.0.2.

Comment 1 Sunil Kondkar 2012-11-27 12:04:54 UTC
Created attachment 652640 [details]
Page view - JON 3.1.2 ER2 build

Comment 2 Sunil Kondkar 2012-11-27 12:09:09 UTC
Created attachment 652643 [details]
Page view - JON 3.1.1 GA build

Comment 3 Sunil Kondkar 2012-11-29 13:37:34 UTC
Observed similar page view issue with 'Administration->Content->Repositories->JBoss Patches' page. Screenshot attached as viewed on Firefox 10.0.2.

Comment 4 Sunil Kondkar 2012-11-29 13:38:13 UTC
Created attachment 654287 [details]
Pageview_Repositories

Comment 5 Mike Thompson 2012-12-06 15:32:37 UTC
I was able to narrow this down to a specific commit that broke this: commit id: b9d4a5f. This commit brings in a different version of jquery as well which is most probably the culprit.



If I build from tag RHQ_4_4_0_JON311GA the issue doesn't exists. If I cherry-pick the commit: b9d4a5f then I see the issue.

Commit b9d4a5f is part of BZ 845277: JBoss ON dashboard shows messed metric graph on IE 8/9] Version of gflot upgraded to 2.4.2 (it contains the excanvas library for IE8/9 support of HTML canvas el.), version of sparkline upgraded to 2.0, version of jquery upgraded to 1.7.2; quick fix: removed the doctype declaration and removed overcasting to int (cherry-picked and merged into one commit from 5d243b3 and 8000e71)

I'm linking these two BZ's and moving BZ845277 back to on_dev as this BZ is a regression from that BZ.

Comment 6 Sunil Kondkar 2012-12-07 13:11:40 UTC
Few more pages where the page view issue is observed on Firefox 10.0.2:

All links in Administration->Topology section
All links in Help->Documentation section
All links in Help->Tutorial section

Comment 7 Jirka Kremser 2012-12-10 16:08:22 UTC
BZ 883946 is probably caused by the same problem.

Comment 8 Charles Crouch 2012-12-11 00:00:34 UTC
(In reply to comment #5)
So looking at the commit which causes this issue,
http://git.fedorahosted.org/cgit/rhq/rhq.git/commit/?h=release/jon3.1.x&id=b9d4a5f99ebc403ad169f7da26a04a6877c95dfa

some questions spring to mind (hopefully at least some of these are not completely useless)...

1) What version of jQuery are we using elsewhere in the code base? I'm presuming this issue is caused by a jQuery conflict?
2) Is is possible to get gflot to use the version of jQuery we are using elsewhere? 
3) Can we upgrade the version were are using elsewhere to the version required by gflot?
4) Can we have gflot use an external version of jquery (the one we use elsewhere) instead of the one it ships with?
5) There are lots of other versions of gflot between 1.0.0 and 2.4.2 are there possible some which would conflict "less"? :
https://code.google.com/p/gflot/downloads/list?can=1&q=
6) Looking at gflot-1.0.0.jar\ca\nanometrics\gflot\GFlot.gwt.xml I see reference to <script src="flot-0.5/excanvas.pack.js"></script> This looks suspiciously like excanvas support in gflot1.0.0?
7) Why did we add <script src="/coregui/js/jquery-1.7.2.min.js"/> to CoreGUI.html if gflot bundles it?
8) Why was jquery.sparkline upgraded?

Comment 9 Jirka Kremser 2012-12-11 13:54:36 UTC
good questions. The good news is that while I was trying to provide the answers I've found the solution. It wasn't happening because of the jquery version conflict as we thought, but because I forgot to cherry-pick commit which removes the "<!DOCTYPE html>" from the main html page. (it is part of the bug 845277 comment 10. My bad.

for the future possible problems with jquery, here are the answers:

1) * JSF+RichFaces use jQuery (don't know the version it looks like it is some proprietary version from Rich Faces, because the word "RichFaces" occurs in it http://localhost:7080/a4j/g/3_3_3.Finalorg/richfaces/renderkit/html/scripts/jquery/jquery.js.xhtml)
   
   * sparkline requires 1.7.2
   * gflot has jquery 1.7.2 inside

3) I was trying to set all the versions to 1.7.2 (JSF has unknown version, but it is in iframe, so it may be fine in the end)

2) 4) looks like <set-property name="gflot.load.jquery" value="ENABLED" /> in gwt descriptor does it

5) In maven central there are only 2.4.0 and higher, the API has been changed, I was trying different versions

6) it was there, but it didn't work

7) sparkline needs in, i know it sounds wierd, but it didn't work without it. I think the jquery for gflot is lazily loaded only if some page with gflot is shown, but pages using glot and pages using sparkline are disjunctive

8) to use the same version of jquery like gflot 1.7.2

Comment 10 Jirka Kremser 2012-12-11 13:55:43 UTC
"<set-property name="gflot.load.jquery" value="ENABLED" />" should be "<set-property name="gflot.load.jquery" value="EXTERNAL" />"

Comment 11 Jirka Kremser 2012-12-11 14:15:08 UTC
http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=f0518a176

branch:  release/jon3.1.x
time:    Wed Aug 15 20:13:14 2012 +0200
commit:  f0518a176b52b043dca9fbb5ec7b3ee74d3a4635
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 845277] - quick fix: removed the doctype declaration and removed overcasting to int (cherry picked from commit 8000e712dd98fd8ee8e1ff52940e15b07f11e782)

..moving status to MODIFIED

Comment 12 Simeon Pinder 2012-12-13 19:18:30 UTC
Moving to ON_QA as new build available to test with:
https://brewweb.devel.redhat.com/buildinfo?buildID=247371

Comment 13 Sunil Kondkar 2012-12-14 08:54:08 UTC
Verified that all mentioned pages look proper on FF 10.0.2. Verified on JON 3.1.2 ER5.


Note You need to log in before you can comment on or make changes to this bug.