Bug 845517 - [remote-viever] Zooming in beyond normal size with vdagent on guest is broken
[remote-viever] Zooming in beyond normal size with vdagent on guest is broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
Depends On:
Blocks: 856678
  Show dependency treegraph
 
Reported: 2012-08-03 05:48 EDT by Tomas Jamrisko
Modified: 2015-03-09 07:30 EDT (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.7-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 856678 (view as bug list)
Environment:
Last Closed: 2015-03-09 07:30:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spice debug log file of virt-viewer (128.05 KB, text/plain)
2013-12-16 22:01 EST, tingting zheng
no flags Details
The original resolution of the guest. (574.81 KB, image/png)
2013-12-17 22:01 EST, tingting zheng
no flags Details
The resolution of the guest after zoom in the first time (554.54 KB, image/png)
2013-12-17 22:04 EST, tingting zheng
no flags Details
The resolution of the guest after zoom in the second time (574.55 KB, image/png)
2013-12-17 22:06 EST, tingting zheng
no flags Details

  None (edit)
Description Tomas Jamrisko 2012-08-03 05:48:59 EDT
Description of problem:

Connecting to a VM with vdagent running and trying to zoom in beyoned normal size results in a frantic behaviour where the window tries to resize itself, and vdagent tries to fit the new window size. After a few iterations  virt-viewer window ends up smaller, and vdagent wins by keeping 1:1 pixel ratio

Version-Release number of selected component (if applicable):
virt-viewer-0.5.3-1.el7.x86_64
virt-viewer-0.5.3-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect to a VM with vdagent
2. Zoom In
  
Actual results:
(see description)

Expected results:

Virt-viewer windows increases its size, VM retains its original resolution
Comment 3 Christophe Fergeau 2013-11-04 05:42:29 EST
Parent bug (rhbz#856678) was fixed upstream and VERIFIED in rhel6.
Comment 5 tingting zheng 2013-11-07 09:02:32 EST
Tested with:
Host:
libvirt-1.1.1-11.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-gtk-0.20-6.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-glib-0.20-6.el7.x86_64

Guest:rhel6.5
spice-vdagent-0.14.0-2.el6.x86_64


Steps:
1. Install a RHEL6.5 guest with gnome.
2. Make sure guest has spice+qxl graphic devices and spicevmc channel exists.
3. Start the guest and make sure spice-vdagentd service is running in guest.
4. Run virt-viewer $guestname.
5. The default resolution of the guest is 1272*720.
6. Zoom In,then the resolution become 1152*720.
7. Zoon In again,the resolution changed again:1056*720.

Step 6 and step 7 shows the bug is still not fixed,so move the bug back to ASSIGNED.
Comment 6 Marc-Andre Lureau 2013-12-12 09:36:31 EST
(In reply to tingting zheng from comment #5)
> Steps:
> 1. Install a RHEL6.5 guest with gnome.
> 2. Make sure guest has spice+qxl graphic devices and spicevmc channel exists.
> 3. Start the guest and make sure spice-vdagentd service is running in guest.
> 4. Run virt-viewer $guestname.
> 5. The default resolution of the guest is 1272*720.
> 6. Zoom In,then the resolution become 1152*720.
> 7. Zoon In again,the resolution changed again:1056*720.
> 
> Step 6 and step 7 shows the bug is still not fixed,so move the bug back to
> ASSIGNED.

I can't reproduce with those instructions using virt-viewer-0.5.7-2.el7.x86_64 and 6.5 guest. Please verify.

Notice that mutter/gnome-shell prevents from growing the window outside the workspace. You have to have the window already partially outside for it to grow larger.
Comment 7 tingting zheng 2013-12-16 00:59:30 EST
(In reply to Marc-Andre Lureau from comment #6)
> (In reply to tingting zheng from comment #5)
> > Steps:
> > 1. Install a RHEL6.5 guest with gnome.
> > 2. Make sure guest has spice+qxl graphic devices and spicevmc channel exists.
> > 3. Start the guest and make sure spice-vdagentd service is running in guest.
> > 4. Run virt-viewer $guestname.
> > 5. The default resolution of the guest is 1272*720.
> > 6. Zoom In,then the resolution become 1152*720.
> > 7. Zoon In again,the resolution changed again:1056*720.
> > 
> > Step 6 and step 7 shows the bug is still not fixed,so move the bug back to
> > ASSIGNED.
> 
> I can't reproduce with those instructions using
> virt-viewer-0.5.7-2.el7.x86_64 and 6.5 guest. Please verify.
> 
> Notice that mutter/gnome-shell prevents from growing the window outside the
> workspace. You have to have the window already partially outside for it to
> grow larger.

I tried with virt-viewer-0.5.7-2.el7.x86_64 and rhel 6.5 guest,the bug can still be reproduced.
Comment 8 Marc-Andre Lureau 2013-12-16 05:17:33 EST
(In reply to tingting zheng from comment #7)
> > I can't reproduce with those instructions using
> > virt-viewer-0.5.7-2.el7.x86_64 and 6.5 guest. Please verify.
> > 
> > Notice that mutter/gnome-shell prevents from growing the window outside the
> > workspace. You have to have the window already partially outside for it to
> > grow larger.
> 
> I tried with virt-viewer-0.5.7-2.el7.x86_64 and rhel 6.5 guest,the bug can
> still be reproduced.

As I can't reproduce,
please provide a recording of the desktop exhibiting the bug.

thanks
Comment 9 Tomas Jamrisko 2013-12-16 05:45:11 EST
Will record if this doesn't help. 

the difference between behaviour of 0.5.6-8.el6 and 0.5.7-2.el7 while zooming in is, that on rhel6 the window keeps on increasing its size indefinitely, whereas on rhel7 the window gets only as large as the desktop. When the size of the window would exceed the resolution of client, the window doesn't get any larger and the guest has its resolution reduced and DPI increased to compensate.

Maybe this is actually intended?
Comment 10 Marc-Andre Lureau 2013-12-16 06:05:11 EST
Eh ok :) Did you read this?

(In reply to Marc-Andre Lureau from comment #6)
> Notice that mutter/gnome-shell prevents from growing the window outside the
> workspace. You have to have the window already partially outside for it to
> grow larger.


This will grow:

              +------------------------+
              | display                |
              |                        |
              |       +----------------------+
              |       | virt-viewer    |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              +-------|----------------+     |
                      |                      |
                      +----------------------+

This won't:



              +------------------------+
              |  display               |
              |                        |
              |   +------------------+ |
              |   | vv               | |
              |   |                  | |
              |   |                  | |
              |   |                  | |
              |   |                  | |
              |   |                  | |
              |   +------------------+ |
              +------------------------+
Comment 11 Tomas Jamrisko 2013-12-16 07:01:33 EST
I didn't :). 

In that case this is most likely a notabug.
Comment 12 tingting zheng 2013-12-16 22:01:58 EST
Created attachment 837529 [details]
spice debug log file of virt-viewer

I can still reproduce this issue,when zoom in,the resolution of guest will changed,attached the log file.
Comment 13 Marc-Andre Lureau 2013-12-17 04:58:46 EST
(In reply to tingting zheng from comment #12)
> Created attachment 837529 [details]
> spice debug log file of virt-viewer
> 
> I can still reproduce this issue,when zoom in,the resolution of guest will
> changed,attached the log file.

please provide a video / screencast recording of the desktop exhibiting the bug.
Comment 15 tingting zheng 2013-12-17 22:01:34 EST
Created attachment 838082 [details]
The original resolution of the guest.
Comment 16 tingting zheng 2013-12-17 22:04:23 EST
Created attachment 838083 [details]
The resolution of the guest after zoom in the first time
Comment 17 tingting zheng 2013-12-17 22:06:42 EST
Created attachment 838086 [details]
The resolution of the guest after zoom in the second time
Comment 18 tingting zheng 2014-01-06 05:33:59 EST
Retested the issue with:
virt-viewer-0.5.7-3.el7.x86_64

When I move the window out of screen then resize,most times resolution will keeep the same,however,when I set original screen as 1024*768 or similar resolution,the resolution will change when zoom in.
Comment 20 Marc-Andre Lureau 2014-07-17 07:29:32 EDT
please verify with new release of virt-viewer-0.6.0-1.el7, and take Comment #10 into account. It works for me, as described.
Comment 21 CongDong 2014-07-23 03:32:42 EDT
I can reproduce with virt-viewer-0.5.7-3.el7.x86_64

Steps:
1. start guest and open with virt-viewer
# virsh start $vm
# virt-viewer $vm
2. set guest's resolution to 1024*768
3. move the window out the screen like this
              +------------------------+
              | display                |
              |                        |
              |       +----------------------+
              |       | virt-viewer    |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              |       |                |     |
              +-------|----------------+     |
                      |                      |
                      +----------------------+
4. View -> zoom -> zoom in several times

Result:
The size of the window changes big, and resolution is changed.

VERIFIED with: virt-viewer-0.6.0-1.el7.x86_64

Step is same with above.

Result:
The size is zoomed, but resolution is not changed.

As the result, set to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.