Bug 856678 - [remote-viever] Zooming in beyond normal size with vdagent on guest is broken
Summary: [remote-viever] Zooming in beyond normal size with vdagent on guest is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 872681 (view as bug list)
Depends On: 845517
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-12 14:52 UTC by Tomas Jamrisko
Modified: 2013-11-07 14:07 UTC (History)
13 users (show)

Fixed In Version: virt-viewer-0.5.2-16.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 845517
Environment:
Last Closed: 2013-02-21 09:33:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0361 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-02-20 20:53:07 UTC

Description Tomas Jamrisko 2012-09-12 14:52:02 UTC
+++ This bug was initially created as a clone of Bug #845517 +++

Description of problem:

Connecting to a VM with vdagent running and trying to zoom in beyoned normal size results in a frantic behaviour where the window tries to resize itself, and vdagent tries to fit the new window size. After a few iterations  virt-viewer window ends up smaller, guests resolution decreases, and vdagent wins by keeping 1:1 pixel ratio

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-9.el6.i386
virt-viewer-0.5.2-9.el6.x86_64
spice-gtk-0.11-11.el6_3.1

How reproducible:
Always

Steps to Reproduce:
1. Connect to a VM with vdagent
2. Increase guests resolution at least 1280x720
2. Zoom In
  
Actual results:
(see description)

Expected results:

Virt-viewer windows increases its size, VM retains its original resolution

Comment 3 Marc-Andre Lureau 2012-10-17 14:54:46 UTC
sent a proposed fix on the ML

https://www.redhat.com/archives/virt-tools-list/2012-October/msg00128.html

Comment 6 tingting zheng 2012-10-29 04:58:16 UTC
I can reproduce this issue with:
virt-viewer-0.5.2-9.el6.x86_64
spice-gtk-0.11-11.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64

Tried with:
virt-viewer-0.5.2-16.el6.x86_64
spice-gtk-0.14-5.el6.x86_64
spice-vdagent-0.12.0-2.el6.x86_64

Steps:
1. Install a RHEL6.3 guest with gnome.
2. Make sure guest has spice+qxl graphic devices and spicevmc channel exists.
3. Start the guest and make sure spice-vdagentd service is running in guest.
4. Run virt-viewer $guestname.
5. Increase guests resolution at least 1280x720
6. Zoom In,try to zoom in beyoned normal size,Virt-viewer windows increases its size, VM retains its original resolution.(repeat several times)

Step6 works well,so change the status of the bug to VERIFIED.

Comment 7 Tomas Jamrisko 2012-11-05 09:05:15 UTC
*** Bug 872681 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2013-02-21 09:33:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0361.html


Note You need to log in before you can comment on or make changes to this bug.