Bug 845594 - Conductor UI does not update provider name in /etc/imagefactory/vsphere.json
Conductor UI does not update provider name in /etc/imagefactory/vsphere.json
Status: CLOSED DUPLICATE of bug 804926
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 10:25 EDT by Aaron Weitekamp
Modified: 2012-08-29 10:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 11:48:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Weitekamp 2012-08-03 10:25:50 EDT
Description of problem:
Changing the "Cloud Resource Provider name" in Cloud Providers for a vSphere account does not update file /etc/imagefactory/vsphere.json causing push to fail.

Version-Release number of selected component (if applicable):
CFCE 1.0.1

# rpm -qa|grep aeolus
aeolus-configure-2.5.10-1.el6cf.noarch
aeolus-conductor-doc-0.8.34-1.el6cf.noarch
aeolus-all-0.8.34-1.el6cf.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.34-1.el6cf.noarch
aeolus-conductor-0.8.34-1.el6cf.noarch


How reproducible: 100%


Steps to Reproduce:
1. in conductor UI, create vSphere provider account
2. change Cloud Resource Provider name
3. build image
4. push to vSphere provider
5. push fails

Actual results:
Changing provider name does not update file /etc/imagefactory/vsphere.json. vSphere push fails. Presumably the same results for RHEV-M provider.

imagefactory.log reports "No matching provider found for vsphere-on-premise, using "condorcloud" by default."

# cat /etc/imagefactory/vsphere.json 
{
  "vsphere-default": <--provider name does not update to match conductor UI
  {
    "api-url":   "https://10.16.120.224/sdk",
    "datastore":    "datastore1",
    "network_name": "VM Network"
  }
}


Expected results:
Changing provider name should update file /etc/imagefactory/vsphere.json. vSphere push should succeed.


Additional info:
Workaround: Change vSphere Cloud Resource Provider name back to original or edit /etc/imagefactory/vsphere.json provider name string to match conductor UI

Provider account connection tests succeed.
Comment 1 Dave Johnson 2012-08-09 11:48:19 EDT

*** This bug has been marked as a duplicate of bug 804926 ***

Note You need to log in before you can comment on or make changes to this bug.