Bug 804926 - Error "Failed. Response code = 500. Response message = Internal Server Error" needs to be handled in conductor
Error "Failed. Response code = 500. Response message = Internal Server Error"...
Status: CLOSED WONTFIX
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-image (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Mike Orazi
Rehana
: FutureFeature
: 845594 (view as bug list)
Depends On:
Blocks: 847798 865833
  Show dependency treegraph
 
Reported: 2012-03-20 04:16 EDT by Rehana
Modified: 2012-12-20 11:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 847798 (view as bug list)
Environment:
Last Closed: 2012-12-20 11:08:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
provider (216.82 KB, image/png)
2012-03-20 04:16 EDT, Rehana
no flags Details
UI (180.03 KB, image/png)
2012-03-20 04:18 EDT, Rehana
no flags Details
rail log (13.44 KB, application/octet-stream)
2012-03-20 04:19 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-03-20 04:16:39 EDT
Created attachment 571313 [details]
provider

Description of problem:

I got this error "Failed. Response code = 500. Response message = Internal Server Error" when i tried to do a "push all" operation from conductor after changing the provider name from "rhevm-default" to "rhevm-default_rehana"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to aeolus
2.Created three provider accounts(rhevm,vsphere,ec2)
3.Changed the default provider name of rhevm from "rhevm-default" to "rhevm-default_rehana"(pfa:provider.png)
3.Build image for two providers i.e for rhevm and vsphere from CLI
4.Clicked on "Push all" button from conductor
  
Actual results:

1. On click of "Push all" button ,in conductor it displayed the below error "Failed. Response code = 500. Response message = Internal Server Error"
(pfa: UI.png, rails.log)

2. On click of 'push' button it displayed the appropriate error message
"Unable to Upload Provider Image"


Expected results:

So i feel either changing default provider name should be disabled(if its not allowed to change the provider name) or the error should be changed to user understandable form. 

Additional info:

rpm -qa | grep aeolus
aeolus-configure-2.5.0-18.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-all-0.8.0-43.el6.noarch
Comment 1 Rehana 2012-03-20 04:18:36 EDT
Created attachment 571314 [details]
UI
Comment 2 Rehana 2012-03-20 04:19:32 EDT
Created attachment 571315 [details]
rail log
Comment 3 Rehana 2012-03-20 07:13:53 EDT
imagefactory log:

2012-03-20 07:12:54,557 ERROR imgfac.rest.imagefactory thread(worker 6) Message: 'template' must be a UUID, URL, XML string or XML document path...
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 191, in push_image
    job = BuildDispatcher().push_image_to_providers(image_id, build_id, (provider, ), credentials)[0]
  File "/usr/lib/python2.6/site-packages/imgfac/BuildDispatcher.py", line 83, in push_image_to_providers
    job = job_cls(template, target, image_id, build_id, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/imgfac/BuildJob.py", line 49, in __init__
    self.template = template if isinstance(template, Template) else Template(template)
  File "/usr/lib/python2.6/site-packages/imgfac/Template.py", line 79, in __init__
    raise ValueError("'template' must be a UUID, URL, XML string or XML document path...")
ValueError: 'template' must be a UUID, URL, XML string or XML document path...
2012-03-20 07:12:54,573 ERROR imgfac.rest.imagefactory thread(worker 6) Message: HTTP Response 500
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 212, in create_provider_image
    return push_image(image_id, build_id, target_image_id)
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 60, in decorated_function
    return f(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 202, in push_image
    raise HTTPResponse(status=500, output=e)
HTTPResponse: HTTP Response 500
Comment 4 Dave Johnson 2012-08-09 11:48:19 EDT
*** Bug 845594 has been marked as a duplicate of this bug. ***
Comment 5 Mike Orazi 2012-08-09 12:06:00 EDT
It looks like we should address this by not allowing the provider name to change.
Comment 6 Angus Thomas 2012-08-15 08:31:11 EDT
Not allowing the provider name to be changed is a temporary hack, to prevent users from triggering the bug.

Making that change is being tracked in #847798

This bug exists to track the real solution, which involved redesigning the way that provider information is stored and passed to components.
Comment 7 Mike Orazi 2012-12-20 11:08:18 EST
This should be addressed as a byproduct of tim integration so I'm closing this as wont_fix in the current stream.

Note You need to log in before you can comment on or make changes to this bug.