Bug 845657 - Man page for numactl does not accurately describe the localalloc option.
Summary: Man page for numactl does not accurately describe the localalloc option.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On:
Blocks: 832743 881779 886216
TreeView+ depends on / blocked
 
Reported: 2012-08-03 19:12 UTC by Travis Gummels
Modified: 2018-11-30 21:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: localalloc option on the numactl(8) manual page was not described properly Consequence: confusing documentation Fix: described localalloc option on the numactl(8) manual page more verbosely Result: clear documentation
Clone Of:
: 881779 (view as bug list)
Environment:
Last Closed: 2013-02-21 10:54:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
--localalloc option manpage patch (562 bytes, patch)
2012-11-23 14:55 UTC, Petr Holasek
no flags Details | Diff
--localalloc option manpage patch (566 bytes, patch)
2012-11-23 15:02 UTC, Petr Holasek
no flags Details | Diff
--localalloc option manpage patch (567 bytes, patch)
2012-11-23 15:08 UTC, Petr Holasek
no flags Details | Diff
--localalloc option manpage patch (565 bytes, patch)
2012-11-23 15:13 UTC, Petr Holasek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0464 normal SHIPPED_LIVE man-pages-overrides bug fix update 2013-02-20 21:07:17 UTC

Description Travis Gummels 2012-08-03 19:12:18 UTC
Description of problem:

Man page for numactl does not accurately describe the localalloc option.

       --localalloc, -l
              Always allocate on the current node.

The assumption the customer makes, which seems reasonable, is that --localalloc would imply: MPOL_BIND.  The documentation for numactl could be clearer that --localalloc falls back to the system default which is local allocation.

Version-Release number of selected component (if applicable):
As shipped with RHEL 6.3

How reproducible:
100%

Steps to Reproduce:
N/A
  
Actual results:


Expected results:


Additional info:
LLNL requests that all bugs logged on their behalf be public facing.

Comment 4 Petr Holasek 2012-11-23 14:55:32 UTC
Created attachment 650480 [details]
--localalloc option manpage patch

Comment 5 Petr Holasek 2012-11-23 15:02:10 UTC
Created attachment 650485 [details]
--localalloc option manpage patch

Comment 6 Petr Holasek 2012-11-23 15:08:43 UTC
Created attachment 650486 [details]
--localalloc option manpage patch

Comment 7 Petr Holasek 2012-11-23 15:13:13 UTC
Created attachment 650487 [details]
--localalloc option manpage patch

Comment 14 errata-xmlrpc 2013-02-21 10:54:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0464.html


Note You need to log in before you can comment on or make changes to this bug.