Bug 845761 - coredump on invalid ports
coredump on invalid ports
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba3x (Show other bugs)
5.9
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Guenther Deschner
qe-baseos-daemons
: Reopened
Depends On: 845760
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 13:34 EDT by Ales Zelinka
Modified: 2013-01-07 22:35 EST (History)
5 users (show)

See Also:
Fixed In Version: samba3x-3.6.6-0.125.el5
Doc Type: Bug Fix
Doc Text:
internal
Story Points: ---
Clone Of: 845760
Environment:
Last Closed: 2013-01-07 22:35:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2012-08-04 13:34:47 EDT
+++ This bug was initially created as a clone of Bug #845760 +++

smbd dumps core when started with "smb ports = 0 0". It's pretty harmless but some input sanitization instead of simply coredumping would be nice especially since it sets off abrt alarm.
Comment 1 RHEL Product and Program Management 2012-08-04 13:48:02 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 errata-xmlrpc 2013-01-07 22:35:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0064.html

Note You need to log in before you can comment on or make changes to this bug.