Bug 845813 - [ovirt-webadmin] - Webadmin Tree pane is not refreshed with new Entities (DCs / Clusters etc...)
[ovirt-webadmin] - Webadmin Tree pane is not refreshed with new Entities (DCs...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Shahar Havivi
Lukas Svaty
ux
: Regression
: 852722 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 06:06 EDT by David Botzer
Modified: 2014-01-13 19:03 EST (History)
9 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:05:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tree_pane-refresh (99.25 KB, image/png)
2012-08-05 06:06 EDT, David Botzer
no flags Details
engine-log (37.89 KB, application/octet-stream)
2012-08-05 06:06 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-08-05 06:06:18 EDT
Created attachment 602346 [details]
tree_pane-refresh

Description of problem:
After creating a new entity the Tree pane is not refreshed, and not displaying the new Entity

Version-Release number of selected component (if applicable):
3.1/si13.1

How reproducible:
Always

Steps to Reproduce:
1.install rhevm
2.create new entity (DC, Cluster)
3.verify it is displayed in the tree pane (DC, Cluster)
  
Actual results:
Entity is not Displayed in tree pane (DC, Cluster)

Expected results:
Should display the new Entity

Additional info:
Attached

Need to logout and login to refresh display
Comment 1 David Botzer 2012-08-05 06:06:50 EDT
Created attachment 602347 [details]
engine-log
Comment 2 Itamar Heim 2012-08-05 07:47:55 EDT
did you click the refresh button on the tree?
Comment 3 David Botzer 2012-08-05 08:03:23 EDT
Yes I have,
And also I changed couple of times the refresh rate between 4 & 20 sec

Another thing that refreshes correctly besides re-login, is
Collapsing the Tree and Expanding it again
Comment 4 Simon Grinberg 2012-08-06 04:04:51 EDT
(In reply to comment #3)

> Another thing that refreshes correctly besides re-login, is
> Collapsing the Tree and Expanding it again

Yap I've noticed that as well: 
To refresh the tree you have too:
1. Click refresh 
2. Collapse all 
3. Expand all 

In 3.0 the refresh button actually did automatically steps 1 and 2. 
It was annoying, since if you only had part of the tree expanded, then to get back to the same view but refreshed you had to click refresh and re-expand the view you wanted.  

Now it keeps the same annoyance but with the added annoyance of clicking refresh and see no change, and then to manually click collapse all in order to get to the same point as in 3.0. IE loos current set view in order to refresh.

Marking as a regression though the preferred solution is not to get to the 3.0 refresh behavior, but to a real refresh. 

Expected results:
Clicking refresh will display, if possible, the updated last view chosen by the user. If those are the elements that were removed so last view can't be presented, only then auto-collapse and expend.
Comment 6 Shahar Havivi 2012-08-21 08:45:59 EDT
posted at: http://gerrit.ovirt.org/#/c/7374/
Comment 7 Shahar Havivi 2012-08-21 09:56:20 EDT
merged at: ff75e338806c8b0b921a8bfeae1982016303f7d4
Comment 9 Einav Cohen 2012-08-26 11:07:08 EDT
(In reply to comment #4)
> ...
> Expected results:
> Clicking refresh will display, if possible, the updated last view chosen by
> the user. If those are the elements that were removed so last view can't be
> presented, only then auto-collapse and expend.

note: this bug is just to fix the regression from 3.0.
preserving the state/selected-item/etc. between refresh actions requires is a bit tricky and is not 3.1 material. please open a rhevm-future RFE if needed.
Comment 11 Shahar Havivi 2012-08-29 12:45:49 EDT
*** Bug 852722 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.