Bug 845920 - SELinux is preventing /usr/sbin/abrt-dbus from 'rmdir' accesses on the directory pyhook-2012-08-03-16:19:54-1061.
SELinux is preventing /usr/sbin/abrt-dbus from 'rmdir' accesses on the direct...
Status: CLOSED DUPLICATE of bug 836769
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:10ea22fb0a499e53ed0ebdd2a0c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 02:50 EDT by yarci
Modified: 2012-08-06 04:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 04:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yarci 2012-08-06 02:50:57 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           Mon 06 Aug 2012 09:50:43 AM EEST

description:
:SELinux is preventing /usr/sbin/abrt-dbus from 'rmdir' accesses on the directory pyhook-2012-08-03-16:19:54-1061.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that abrt-dbus should be allowed rmdir access on the pyhook-2012-08-03-16:19:54-1061 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep abrt-dbus /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                pyhook-2012-08-03-16:19:54-1061 [ dir ]
:Source                        abrt-dbus
:Source Path                   /usr/sbin/abrt-dbus
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           abrt-dbus-2.0.10-4.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.x86_64 #1 SMP Mon Jul 30
:                              14:48:59 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 06 Aug 2012 09:46:33 AM EEST
:Last Seen                     Mon 06 Aug 2012 09:46:33 AM EEST
:Local ID                      88bbc3ec-ebcb-4178-96bc-29b53ede6422
:
:Raw Audit Messages
:type=AVC msg=audit(1344235593.710:60): avc:  denied  { rmdir } for  pid=1514 comm="abrt-dbus" name="pyhook-2012-08-03-16:19:54-1061" dev="sda5" ino=1308238 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1344235593.710:60): arch=x86_64 syscall=rmdir success=yes exit=0 a0=2100d80 a1=ffffffff a2=329f9b0740 a3=32a9610ec6 items=0 ppid=1 pid=1514 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-dbus exe=/usr/sbin/abrt-dbus subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)
:
:Hash: abrt-dbus,abrt_t,user_home_t,dir,rmdir
:
:audit2allow
:
:#============= abrt_t ==============
:allow abrt_t user_home_t:dir rmdir;
:
:audit2allow -R
:
:#============= abrt_t ==============
:allow abrt_t user_home_t:dir rmdir;
:
Comment 1 Miroslav Grepl 2012-08-06 04:58:37 EDT

*** This bug has been marked as a duplicate of bug 836769 ***

Note You need to log in before you can comment on or make changes to this bug.