Bug 836769 - SELinux is preventing /usr/sbin/abrt-dbus from 'write' accesses on the directory /home/marcio/.abrt/spool/ccpp-2012-06-21-18:35:34-2169.
SELinux is preventing /usr/sbin/abrt-dbus from 'write' accesses on the direct...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
abrt_hash:850a9e9cd21b1208b0b099f0595...
:
: 842934 845913 845920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 02:16 EDT by marciobraz2010
Modified: 2012-10-02 03:30 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 03:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marciobraz2010 2012-07-01 02:16:59 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.3-1.fc17.x86_64
time:           Dom 01 Jul 2012 03:16:51 BRT

description:
:SELinux is preventing /usr/sbin/abrt-dbus from 'write' accesses on the directory /home/marcio/.abrt/spool/ccpp-2012-06-21-18:35:34-2169.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If você acredita que o abrt-dbus deva ser permitido acesso de write em ccpp-2012-06-21-18:35:34-2169 directory  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:Do
:permitir este acesso agora executando:
:# grep abrt-dbus /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                /home/marcio/.abrt/spool/ccpp-2012-06-21-18:35:34-
:                              2169 [ dir ]
:Source                        abrt-dbus
:Source Path                   /usr/sbin/abrt-dbus
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           abrt-dbus-2.0.10-4.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-134.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.3-1.fc17.x86_64 #1
:                              SMP Mon Jun 18 19:53:17 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Dom 01 Jul 2012 03:09:48 BRT
:Last Seen                     Dom 01 Jul 2012 03:09:48 BRT
:Local ID                      cabfe4e9-67a9-464d-815a-98ce56323383
:
:Raw Audit Messages
:type=AVC msg=audit(1341122988.658:130): avc:  denied  { write } for  pid=2397 comm="abrt-dbus" name="ccpp-2012-06-21-18:35:34-2169" dev="dm-2" ino=10617442 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1341122988.658:130): avc:  denied  { add_name } for  pid=2397 comm="abrt-dbus" name=".lock" scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1341122988.658:130): avc:  denied  { create } for  pid=2397 comm="abrt-dbus" name=".lock" scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_home_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1341122988.658:130): arch=x86_64 syscall=symlink success=yes exit=0 a0=7fff04409d00 a1=7fff04409c80 a2=35e8547322 a3=35f0410d4c items=0 ppid=1 pid=2397 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-dbus exe=/usr/sbin/abrt-dbus subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)
:
:Hash: abrt-dbus,abrt_t,user_home_t,dir,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-07-18 17:04:56 EDT
Why is abrt writing to your homedir?
Comment 2 Jiri Moskovcak 2012-07-19 06:32:02 EDT
It's a bug.
Comment 3 Jakub Filak 2012-07-30 12:56:30 EDT
*** Bug 842934 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Filak 2012-08-06 03:17:34 EDT
*** Bug 845913 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2012-08-06 04:58:37 EDT
*** Bug 845920 has been marked as a duplicate of this bug. ***
Comment 7 Stuart D Gathman 2012-09-12 15:19:17 EDT
That part (writing home dir) is fixed, but now abrt insists on using the retrace server without asking.  I reported that when leaving karma on above release, but will look for a proper bug report now.
Comment 8 Stuart D Gathman 2012-10-01 16:32:10 EDT
abrt-2.0.13 is now able to submit coredumps again.  Close?
Comment 9 Jiri Moskovcak 2012-10-02 03:30:34 EDT
Thanks for the info -> closing.

Note You need to log in before you can comment on or make changes to this bug.