Bug 846077 - ntpd service does not start
ntpd service does not start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 846303
  Show dependency treegraph
 
Reported: 2012-08-06 14:14 EDT by Martin Kosek
Modified: 2012-08-07 16:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 846303 (view as bug list)
Environment:
Last Closed: 2012-08-07 16:07:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Removes dependency on system-timedated-ntp.target (268 bytes, patch)
2012-08-07 11:14 EDT, Michal Sekletar
no flags Details | Diff

  None (edit)
Description Martin Kosek 2012-08-06 14:14:29 EDT
Description of problem:
ntpd service always fails to start:

# systemctl start ntpd.service
Failed to issue method call: Unit systemd-timedated-ntp.target failed to load: No such file or directory. See system logs and 'systemctl status systemd-timedated-ntp.target' for details.

It seems that the systemd-timedated-ntp.target file is missing:
# ls /usr/lib/systemd/system/systemd-timedated-ntp.target
ls: cannot access /usr/lib/systemd/system/systemd-timedated-ntp.target: No such file or directory

Version-Release number of selected component (if applicable):
systemd-187-3.fc18.x86_64
ntp-4.2.6p5-3.fc18.x86_64


How reproducible:

Steps to Reproduce:
1. Install ntp package
2. Try to start ntpd service
3.
  
Actual results:
Commands fails due to missing target file

Expected results:
Command does not fail
Comment 1 Martin Kosek 2012-08-07 04:59:12 EDT
Relevant item from systemd NEWS:

        * timedated will now read known NTP implementation unit names
          from /usr/lib/systemd/ntp-units.d/*.list,
          systemd-timedated-ntp.target has been removed.
Comment 2 David Both 2012-08-07 09:46:09 EDT
I have this problem with Fedora 17. Manual start <systemctl start ntpd.service> does start NTPD but it never starts on reboot.

Installed Packages
ntp.i686 4.2.6p5-2.fc17  @fedora 
systemd.i686 44-17.fc17  @updates
Comment 3 Miroslav Lichvar 2012-08-07 10:52:55 EDT
The new hooking system seems to be described at:

http://www.freedesktop.org/wiki/Software/systemd/timedated

For F17, the relavant bug is bug #821813.
Comment 4 Michal Sekletar 2012-08-07 11:14:45 EDT
Created attachment 602787 [details]
Removes dependency on system-timedated-ntp.target

Patch removes dependency on non-existing target. For more information on systemd-timedated please see[1].

References:
[1] http://www.freedesktop.org/wiki/Software/systemd/timedated
Comment 5 Miroslav Lichvar 2012-08-07 16:07:45 EDT
Should be fixed in ntp-4.2.6p5-4.fc18. Thanks.

Note You need to log in before you can comment on or make changes to this bug.