Bug 846303 - chrony service does not start
chrony service does not start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: chrony (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 857199 (view as bug list)
Depends On: 846077
Blocks: 853666
  Show dependency treegraph
 
Reported: 2012-08-07 07:53 EDT by Martin Kosek
Modified: 2012-09-18 16:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 846077
Environment:
Last Closed: 2012-09-18 16:02:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kosek 2012-08-07 07:53:13 EDT
chrony has the same issue as ntpd:

# service chrony start
Redirecting to /bin/systemctl start  chrony.service
Failed to issue method call: Unit chrony.service failed to load: No such file or directory. See system logs and 'systemctl status chrony.service' for details.

# rpm -q chrony
chrony-1.27-0.4.pre1.fc18.x86_64

+++ This bug was initially created as a clone of Bug #846077 +++

Description of problem:
ntpd service always fails to start:

# systemctl start ntpd.service
Failed to issue method call: Unit systemd-timedated-ntp.target failed to load: No such file or directory. See system logs and 'systemctl status systemd-timedated-ntp.target' for details.

It seems that the systemd-timedated-ntp.target file is missing:
# ls /usr/lib/systemd/system/systemd-timedated-ntp.target
ls: cannot access /usr/lib/systemd/system/systemd-timedated-ntp.target: No such file or directory

Version-Release number of selected component (if applicable):
systemd-187-3.fc18.x86_64
ntp-4.2.6p5-3.fc18.x86_64


How reproducible:

Steps to Reproduce:
1. Install ntp package
2. Try to start ntpd service
3.
  
Actual results:
Commands fails due to missing target file

Expected results:
Command does not fail

--- Additional comment from mkosek@redhat.com on 2012-08-07 04:59:12 EDT ---

Relevant item from systemd NEWS:

        * timedated will now read known NTP implementation unit names
          from /usr/lib/systemd/ntp-units.d/*.list,
          systemd-timedated-ntp.target has been removed.
Comment 1 Fedora Update System 2012-09-11 14:42:05 EDT
chrony-1.27-0.5.pre1.git1ca844.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/chrony-1.27-0.5.pre1.git1ca844.fc18
Comment 2 Fedora Update System 2012-09-12 15:14:45 EDT
Package chrony-1.27-0.5.pre1.git1ca844.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing chrony-1.27-0.5.pre1.git1ca844.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13883/chrony-1.27-0.5.pre1.git1ca844.fc18
then log in and leave karma (feedback).
Comment 3 Miroslav Lichvar 2012-09-13 16:05:30 EDT
*** Bug 857199 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-09-18 16:02:47 EDT
chrony-1.27-0.5.pre1.git1ca844.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.