Bug 846288 - cannot open docx document, sometimes crashes
cannot open docx document, sometimes crashes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Tardon
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 06:54 EDT by Toni Willberg
Modified: 2013-04-08 16:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-08 16:25:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2012-08-07 06:54:24 EDT
Description of problem:

 Libreoffice writer crashes or sometimes silently closes when opening a docx document.

Version-Release number of selected component (if applicable):

 libreoffice-writer-3.4.5.2-16.1.el6_3.x86_64
 libreoffice-core-3.4.5.2-16.1.el6_3.x86_64

How reproducible:
 always

Steps to Reproduce:
1. open a docx document
2. writer tries to open
3. crahes
  
Actual results:
 crash, segfault

Expected results:
 document opens

Additional info:
 I will attach a private non-public test document in next comment.


Similar problem as in bug #713596
Comment 2 Toni Willberg 2012-08-07 06:57:51 EDT
Detaching after fork from child process 10132.
/builddir/build/BUILD/libreoffice-3.4.5.2/writerfilter/source/dmapper/GraphicImport.cxx:1505 failed. Message :GraphicCrop

Program received signal SIGSEGV, Segmentation fault.
0x00007fffcf538a89 in SwNodeIndex::SwNodeIndex(SwNodeIndex const&, long) () from /usr/lib64/libreoffice/program/../basis-link/program/libswlx.so
(gdb) bt
#0  0x00007fffcf538a89 in SwNodeIndex::SwNodeIndex(SwNodeIndex const&, long) () from /usr/lib64/libreoffice/program/../basis-link/program/libswlx.so
#1  0x00007fffcf4743cf in SwPosition::SwPosition(SwNodeIndex const&) () from /usr/lib64/libreoffice/program/../basis-link/program/libswlx.so
#2  0x00007fffcf4747e5 in SwPaM::SwPaM(SwNodeIndex const&, SwNodeIndex const&, long, long, SwPaM*) ()
   from /usr/lib64/libreoffice/program/../basis-link/program/libswlx.so
#3  0x00007fffcf54ab38 in SwDoc::TextToTable(std::vector<std::vector<SwNodeRange, std::allocator<SwNodeRange> >, std::allocator<std::vector<SwNodeRange, std::allocator<SwNodeRange> > > > const&) () from /usr/lib64/libreoffice/program/../basis-link/program/libswlx.so
#4  0x00007fffcf883578 in ?? () from /usr/lib64/libreoffice/program/../basis-link/program/libswlx.so
#5  0x00007fffcd1aee2c in ?? () from /usr/lib64/libreoffice/program/../basis-link/program/libwriterfilterlx.so

(sorry no debuginfo available at this time)
Comment 4 Caolan McNamara 2012-08-07 09:11:06 EDT
caolanm->dtardon: can you check if this is a duplicate of the other .docx table crashing bug ?
Comment 5 David Tardon 2012-08-07 10:26:31 EDT
The one referenced in comment 0? Definitely not. Anyway, the docx causes crash of libreoffice-3.4.5.2-17.fc16, but upstream 3.5 from git opens it fine, so it has been fixed already.
Comment 6 RHEL Product and Program Management 2012-09-07 01:36:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2013-04-08 16:25:59 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.