Bug 846327 - [ovirt-webadmin] - Webadmin - enlarge "Storage domain dialogue window" to allow seeing long target names
[ovirt-webadmin] - Webadmin - enlarge "Storage domain dialogue window" to all...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Daniel Erez
Leonid Natapov
storage
:
: 833036 853367 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 09:23 EDT by David Botzer
Modified: 2016-02-10 11:33 EST (History)
12 users (show)

See Also:
Fixed In Version: SI18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
expand (125.86 KB, image/png)
2012-08-07 09:23 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-08-07 09:23:08 EDT
Created attachment 602749 [details]
expand

Description of problem:
Cannot resize the Storage domain Dialogue window,
Thus cannot see the name given to a LUN

Version-Release number of selected component (if applicable):
3,1/si13.1

How reproducible:
always

Steps to Reproduce:
1.create new Storage domain
2.Look for a new LUN created, 
  
Actual results:
I can see the IQN without the name given on the storage server

Expected results:
Allow resize of Dialogue window should shwo full name

Additional info:
pic
Comment 4 Einav Cohen 2012-08-09 09:03:20 EDT
in any case, we will need to introduce a dialog-resizing ability to the GUI infrastructure, even if applied initially only to the storage dialog.
Comment 7 Daniel Erez 2012-08-09 16:00:00 EDT
* Regarding the target name, it can still be viewed by hovering on it (a tool-tip with the full name is shown).
* Regarding the dialog current dimensions, is there any kind of estimation of how long a target name could be?
Comment 8 David Botzer 2012-08-12 01:20:20 EDT
From my point of view, the same way we had with WPF, to see the whole name 
- not via tooltip (Since I would need to go over each LUN to find my LUN).

Especially the last part (not the first part -  the iqn part)
Comment 9 Itamar Heim 2012-08-14 11:04:22 EDT
for now, just change this dialog to be big enough.
Comment 12 Einav Cohen 2012-08-26 09:00:52 EDT
bug 851845 on dialog resizing has been opened.
Comment 13 Daniel Erez 2012-08-28 16:02:05 EDT
patches sent upstream:
* http://gerrit.ovirt.org/#/c/7554/ 
Adding resizable dialogs support to UI infrastructure. 
* http://gerrit.ovirt.org/#/c/7555/ 
Enabling resizing *only* for Storage and Disk dialogs
(since some dialogs require adjustments of their inner widgets
for proper resizing).

Resizing support for all dialogs should be revisited as part of:
https://bugzilla.redhat.com/show_bug.cgi?id=851845
Comment 14 Itamar Heim 2012-08-31 05:06:24 EDT
*** Bug 853367 has been marked as a duplicate of this bug. ***
Comment 16 Allon Mureinik 2012-09-04 06:38:07 EDT
Merged Iec5acd2fdc6aafebecf306b2be3b4a2f53b1cf62
Comment 17 Allon Mureinik 2012-09-04 06:40:13 EDT
correction, I7413550422d7e67acb7b8ac94ba59bb8d5c68c1f
Comment 18 Leonid Natapov 2012-09-20 07:25:59 EDT
si18. fixed.
Comment 19 Daniel Erez 2012-09-24 13:52:34 EDT
*** Bug 833036 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.