Bug 846362 - [jboss-as5] Shutdown max wait time "shared" between different resources
[jboss-as5] Shutdown max wait time "shared" between different resources
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 3.1.0
Unspecified Unspecified
low Severity high
: ER01
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On: 879065 879066
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 10:49 EDT by Lukas Krejci
Modified: 2014-01-02 15:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 879065 879066 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (3.21 KB, text/plain)
2012-08-07 10:49 EDT, Lukas Krejci
no flags Details

  None (edit)
Description Lukas Krejci 2012-08-07 10:49:18 EDT
Created attachment 602782 [details]
proposed patch

Description of problem:
This is a concurrency issue.

The problem is that while a shutdown operation on some AS5 resource is in progress, executing the shutdown operation on another AS5 resource on the same agent will override the max wait time of the two operations to the same value defined by the latter resource.

Version-Release number of selected component (if applicable):
4.5.0-SNAPSHOT

How reproducible:
always

Steps to Reproduce:
1. have 2 AS5 resources in inventory, make sure their shutdown takes more than 1 minute (not sure how to do this actually - possibly install a custom MBean that implements MBeanRegistration interface and sleep in preDeregister()?)
2. set the max wait time of 1 to 15 minutes, and 1minute on the other (2).
3. run shutdown on 1.
4. immediatelly run shutdown on 2
  
Actual results:
The operation on the server 1 times out after 1 minute

Expected results:
The operation on the server 1 should only timeout after 15 minutes or complete normally.

Additional info:
Comment 1 mark yarborough 2012-11-20 15:45:46 EST
Per triage with loleary, crouch, mfoley: Move to JBoss ON product, set target release JON 3.2, clear priority (will be subject to further triage in JON 3.2 timeframe).
Comment 2 Heiko W. Rupp 2013-08-09 12:08:38 EDT
Thomas, if there is time left, could you look into this?
Comment 3 Thomas Segismont 2013-08-14 10:53:12 EDT
Fixed in master

commit 2a21d7b3a9a97248df2ab6d9d83804663c55972b
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Wed Aug 14 16:51:00 2013 +0200
Comment 4 Filip Brychta 2013-12-09 05:50:58 EST
Verified on
Version :	
3.2.0.CR1
Build Number :	
6ecd678:d0dc0b6

Note You need to log in before you can comment on or make changes to this bug.