Bug 879066 - [jboss-as5] Shutdown max wait time "shared" between different resources
[jboss-as5] Shutdown max wait time "shared" between different resources
Status: CLOSED DUPLICATE of bug 879065
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 846362
  Show dependency treegraph
 
Reported: 2012-11-21 19:15 EST by Larry O'Leary
Modified: 2013-08-14 09:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 846362
Environment:
Last Closed: 2013-08-14 09:21:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2012-11-21 19:15:00 EST
+++ This bug was initially created as a clone of Bug #846362 +++

Created attachment 602782 [details]
proposed patch

Description of problem:
This is a concurrency issue.

The problem is that while a shutdown operation on some AS5 resource is in progress, executing the shutdown operation on another AS5 resource on the same agent will override the max wait time of the two operations to the same value defined by the latter resource.

Version-Release number of selected component (if applicable):
4.5.0-SNAPSHOT

How reproducible:
always

Steps to Reproduce:
1. have 2 AS5 resources in inventory, make sure their shutdown takes more than 1 minute (not sure how to do this actually - possibly install a custom MBean that implements MBeanRegistration interface and sleep in preDeregister()?)
2. set the max wait time of 1 to 15 minutes, and 1minute on the other (2).
3. run shutdown on 1.
4. immediatelly run shutdown on 2
  
Actual results:
The operation on the server 1 times out after 1 minute

Expected results:
The operation on the server 1 should only timeout after 15 minutes or complete normally.

Additional info:

--- Additional comment from mark yarborough on 2012-11-20 15:45:46 EST ---

Per triage with loleary, crouch, mfoley: Move to JBoss ON product, set target release JON 3.2, clear priority (will be subject to further triage in JON 3.2 timeframe).
Comment 1 Thomas Segismont 2013-08-14 09:21:28 EDT

*** This bug has been marked as a duplicate of bug 879065 ***

Note You need to log in before you can comment on or make changes to this bug.