Bug 846514 - Need to default add rel="no-follow" on comment links to discourage spam postings wanting seo backlinks
Need to default add rel="no-follow" on comment links to discourage spam posti...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 21:47 EDT by Steve Goodwin
Modified: 2015-05-14 21:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: devenv_2008
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 11:28:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Goodwin 2012-08-07 21:47:13 EDT
Description of problem:

It was brought up awhile ago that we should by default, include rel="nofollow" on all links in comments. Otherwise we are inviting spammers to post comments with links to their sites in order to gain seo backlinks.


http://en.wikipedia.org/wiki/Nofollow


Recent examples
https://openshift.redhat.com/community/comment/reply/11392/22363
https://openshift.redhat.com/community/comment/reply/11459/22727
Comment 1 Fabiano Franz 2012-08-16 18:12:34 EDT
Fixed by adding rel="nofollow" to all links in comments. 

https://github.com/openshift/li/pull/248
devenv_2008
Comment 2 Yujie Zhang 2012-08-17 05:48:49 EDT
(In reply to comment #1)
Tested using external links like "www.baidu.com" or "www.google.com", it will be embeded like "https://ec2-23-22-203-28.compute-.amazonaws.com/community/forums/express/www.google.com", so can not redirect to external site from links in our comments, thanks.
Comment 3 Clayton Coleman 2012-11-19 10:43:29 EST
This can be handled by the input filter.
Comment 4 Clayton Coleman 2012-11-19 10:44:21 EST
We need to create a separate input format on production for comments with the "Spam deterrent" checkbox created.  I'm reverting the fix in production because it was the cause of bug 869203
Comment 5 Clayton Coleman 2012-11-19 11:04:05 EST
If we change the default format then all content created by most users will default to having nofollow - which includes content created in blog posts and forum threads.
Comment 6 Clayton Coleman 2012-11-19 11:28:45 EST
Created a story to cover this https://rally1.rallydev.com/#/4670513817d/detail/userstory/9535973774

Note You need to log in before you can comment on or make changes to this bug.