Bug 869203 - The website community did not support Chinese comments.
The website community did not support Chinese comments.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 05:20 EDT by Mengjiao Gao
Modified: 2015-05-14 21:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-19 14:26:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Chinese comments displayed as a mess when clicked "save" to add. (133.83 KB, image/png)
2012-10-23 05:20 EDT, Mengjiao Gao
no flags Details
Chinese comments displayed well on devenv_2500 (124.98 KB, image/png)
2012-11-19 21:10 EST, Mengjiao Gao
no flags Details

  None (edit)
Description Mengjiao Gao 2012-10-23 05:20:58 EDT
Created attachment 631982 [details]
The Chinese comments displayed as a mess when clicked "save" to add.

Description of problem:
When I tested on devenv_2364,I am successful to post a new thread use Chinese. But when I tried to add a Chinese comments to the thread, I got messy words as the attachment shown.
Since I am not sure whether the website should support the Chinese comments or not, I put this bug as a low one.
The product website have the same issue.

Version-Release number of selected component (if applicable):
devenv_2364,product

How reproducible:
always

Steps to Reproduce:
1.Go to /community and login.
2.Go to the forum page, and try to add Chinese comments to a thread .
3.
  
Actual results:
The Chinese comments displayed as a mess when clicked "save" to add.

Expected results:
These comments should displayed well.

Additional info:
The same issue exists when I try to add comments to feachers or blogs.
Comment 1 Clayton Coleman 2012-11-19 10:46:23 EST
This was caused by an earlier fix in bug 846514.  I'm reverting that fix because there's an easier way to fix it in production.  Revert in https://github.com/openshift/li/pull/637
Comment 2 Mengjiao Gao 2012-11-19 21:08:35 EST
Tested this issue on devenv_2500, and the Chinese comments can be displayed well now. So put this issue to verified.
Comment 3 Mengjiao Gao 2012-11-19 21:10:10 EST
Created attachment 648232 [details]
Chinese comments displayed well on devenv_2500

Note You need to log in before you can comment on or make changes to this bug.