Bug 84656 - "nv" driver doesn't work with geforce4 ti 4200
"nv" driver doesn't work with geforce4 ti 4200
Status: CLOSED DUPLICATE of bug 88360
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks: 82784
  Show dependency treegraph
 
Reported: 2003-02-19 22:07 EST by Charles
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XF86Config file (3.13 KB, text/plain)
2003-02-20 14:15 EST, Charles
no flags Details
Xfree86 log file (31.02 KB, text/plain)
2003-02-20 14:15 EST, Charles
no flags Details

  None (edit)
Description Charles 2003-02-19 22:07:37 EST
Description of problem:  Blank screen after anaconda probe; likely due to nvidia
geforce4 ti 4200


Version-Release number of selected component (if applicable):Phoebe 3 - 8.0.94


How reproducible:  Install beta, go through anaconda probe


Steps to Reproduce:
1.  Insert CD1, boot computer
2.  Press enter to install graphically
3.  Press skip to skip media check
    
Actual results:  After skipping media check, anaconda probes hardware, then
screen blanks and can't see anything.


Expected results:  Graphical install


Additional info:  According to the release notes, the tweaked "nv" driver is
supposed to support geforce4 cards, but it does not support mine (Geforce4 Ti
4200).  Install can proceed normally using "text" mode and then switching to the
"vesa" driver in XF86Config, but it would be preferable that the "nv" driver
support the geforce4 ti 4200 in 2d mode out of the box.
Comment 1 Mike A. Harris 2003-02-19 23:23:42 EST
Using the "nv" driver and our latest XFree86 build, please attach your X server
log and config file from a failed attempt to use X.  Please explain the
complete details of what does not work.
Comment 2 Charles 2003-02-20 14:15:10 EST
Created attachment 90224 [details]
XF86Config file
Comment 3 Charles 2003-02-20 14:15:41 EST
Created attachment 90225 [details]
Xfree86 log file
Comment 4 Charles 2003-02-20 14:18:05 EST
Updated from rawhide to XFree build dated 2/19.  Still no joy.  X appears to
start since it doesn't crash to terminal, but I get a blank screen and green
light blinking on monitor.  Attached XFree86 log and XF86Config file.

Full h/w specs:

Epox 8KHA+ mobo
Athlon 2000+ XP cpu
512 MB PC2100 ram
Xtacy Geforce4 Ti 4200 AGP card w/ 64mb mem
ATI allinwonder VE TV capture card
Samsung Syncmaster 172T LCD monitor

Thanks.
Comment 5 Charles 2003-02-20 14:20:35 EST
One more thing:  the attached XF86Config file shows "vesa" driver.  I had
changed it to "nv" after updating XFree to test.  Had to change it back to
"vesa" to log into phoebe3 graphically.
Comment 6 Charles 2003-02-21 15:37:56 EST
Additional comment:  on pheobe mailing list, it seems others have similar 
issues (see thread entitled "Phoebe3 no worky with 
Radeon9500Pro/SonyFlatPanel").  One reader commented that it could be b/c of 
DVI rather than analog VGA port.  I too use DVI rather than analog so maybe it 
is related.

BTW:  the gui install works fine with RH 8.0 on this same box.
Comment 7 Charles 2003-02-22 10:25:30 EST
I have confirmed that switching from DVI to analog VGA between my geforce4 and
my LCD allows me to install graphically.  So, I think it has something to do
with DVI, not the "nv" driver.  See my XFree86 log previously attached.
Comment 8 Mike A. Harris 2003-04-08 11:41:19 EDT
The "nv" driver doesn't fully support DVI, and so Red Hat Linux doesn't
officially support Nvidia hardware using DVI panels either.  Nvidia
are the only ones who can fix this as doing so requires having both the
hardware, the technical specifications (of which only Nvidia has) and
intimate knowledge of the way nvidia hardware works (of which only Nvidia
has).

So unfortunately there is nothing that Red Hat can do about this problem
other than wait for XFree86 upstream "nv" driver to have better DVI support,
and include it in a future distribution release.

Please report this problem in upstream XFree86 bugzilla so the "nv" driver
maintainer is aware of the problem and can improve the DVI support.  If
you like, once reported upstream you can include the URL here and I will
track any upstream progress and perhaps backport any improvements that
nVidia contributes to X development.
Comment 9 Mike A. Harris 2003-07-17 06:21:11 EDT
I'm processing UPSTREAM flagged bug reports for upstream fixes currently, and
noticed that this bug was flagged upstream but has no upstream bug URL, and I
was unable to find an upstream bug report of this issue in XFree86 bugzilla
located at:

    http://bugs.xfree86.org

Closing bug report as WONTFIX as I'm unable to track upstream until a bug
report has been filed upstream, and the URL provided for tracking.  If this
issue is still relevant in the latest XFree86 packages in rawhide, after
reporting upstream at http://bugs.xfree86.org, feel free to add the bug
report URL to this report and reopen if you'd like the issue to be tracked
and any fixes from upstream investigated for inclusion in future Red Hat
XFree86 updates.

Comment 10 Mike A. Harris 2003-09-26 20:59:19 EDT

*** This bug has been marked as a duplicate of 88360 ***
Comment 11 Red Hat Bugzilla 2006-02-21 13:51:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.