Bug 84664 - gnome-volume-control compiled with wrong sound drivers?
gnome-volume-control compiled with wrong sound drivers?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Jay Turner
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-02-19 23:40 EST by Chris Ricker
Modified: 2015-01-07 19:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-26 13:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-02-19 23:40:41 EST
With beta5, I get:

Warning: this version of the Gnome Volume Control was compiled with OSS version
3.8.2, and your system is running version 16502.188.158.

when running gnome-volume-control

I don't recall seeing this in beta4 or previous....
Comment 1 Havoc Pennington 2003-08-06 17:08:45 EDT
Still there?

Looks like some kind of silly number-parsing bug or something.
Comment 2 Chris Ricker 2003-08-06 17:12:34 EDT
I don't have a severn box handy, but on a fully up2date RHL 9 I get:

[cricker@yoshimi mp3s]$ gnome-volume-control 
Warning: This version of the Gnome Volume Control was compiled with
OSS version 3.8.2, and your system is running
version 19896.236.158.
Comment 3 Chris Ricker 2003-08-06 17:18:32 EDT
From the strace, it looks like it's trying to grovel /dev/{,sound/}mixer1, which
doesn't exist. First it pokes /dev/mixer for some info:

13281 open("/dev/mixer", O_RDWR)        = 16
13281 ioctl(16, OSS_GETVERSION, 0xbfffe0bc) = 0
13281 ioctl(16, SOUND_OLD_MIXER_INFO, 0x805a1bc) = 0

then it pokes mixer1, fails, and warns

13281 open("/dev/mixer1", O_RDWR)       = -1 ENODEV (No such device)
13281 open("/dev/mixer1", O_RDWR)       = -1 ENODEV (No such device)
13281 open("/dev/sound/mixer1", O_RDWR) = -1 ENOENT (No such file or directory)
13281 ioctl(-1, OSS_GETVERSION, 0xbfffe0bc) = -1 EBADF (Bad file descriptor)
13281 write(2, "Warning: This version of the Gno"..., 137) = 137
13281 ioctl(-1, SOUND_OLD_MIXER_INFO, 0x8086f54) = -1 EBADF (Bad file descriptor)


That's with gnome-media-2.2.1.1-4

Comment 4 Havoc Pennington 2003-08-06 17:20:39 EDT
Ugh, looks like pretty dorky code.

Should be easy to fix though, just handle that error properly.
Comment 5 Colin Walters 2004-07-26 13:23:45 EDT
Looks fine to me now, closing.

Note You need to log in before you can comment on or make changes to this bug.