Bug 846835 - %include no longer works in %packages section of kickstart
%include no longer works in %packages section of kickstart
Status: CLOSED DUPLICATE of bug 827269
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 16:51 EDT by John Florian
Modified: 2012-08-09 13:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 12:31:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Florian 2012-08-08 16:51:19 EDT
Description of problem:
For modularity and other reasons, I have kickstarts using the %include directive in the %packages section and have done so dating back to Fedora 10.  In Fedora 17, this no longer works.

Version-Release number of selected component (if applicable):
livecd-tools-17.11-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. Customize a trivial kickstart, say /tmp/test.ks, so as to have %packages mention something like "%include /tmp/test-packages.ks"
2. Create /tmp/test-packages.ks with a list of a few package names, just like they might appear in the %packages section.
3. Try to create ISO image using /tmp/test.ks.

Actual results:
I receive an error message like:
Error creating Live CD : Failed to find package '%include /tmp/test-packages.ks' : No package(s) available to install


Expected results:
Should create ISO image as if packages named in /tmp/test-packages.ks were included directly within /tmp/test.ks.


Additional info:
The last spin I'd made with livecd-tools was on Fedora 16, about a few weeks ago, and that worked fine.  I believe I used livecd-tools-16.15-1.fc16.x86_64 since I see that was installed May 23, 2012.
Comment 1 Brian Lane 2012-08-08 18:07:47 EDT
What version of pykickstart do you have installed?
Comment 2 John Florian 2012-08-09 08:07:38 EDT
pykickstart-1.99.7-1.fc17.noarch on the (buggy) F17 box.
pykickstart-1.99.4-1.fc16.noarch on the (good) F16 box.
Comment 3 Brian Lane 2012-08-09 12:31:45 EDT
f17 needs a new pykickstart build.

*** This bug has been marked as a duplicate of bug 827269 ***
Comment 4 Mike Burns 2012-08-09 12:42:11 EDT
fwiw, the f18 version works correctly, so you can:

yum install fedora-release-rawhide
yum update --enablerepo=rawhide pykickstart
Comment 5 John Florian 2012-08-09 13:15:39 EDT
Brian/Mike, thank you for the prompt info and work-around.

Note You need to log in before you can comment on or make changes to this bug.