This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 846908 - Empathy doesn't open after upgrading to version 3.5.4.1-2.fc18
Empathy doesn't open after upgrading to version 3.5.4.1-2.fc18
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: Reopened
: 847514 849701 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-08-09 01:52 EDT by Abhay
Modified: 2012-11-30 14:08 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 14:08:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Abhay 2012-08-09 01:52:15 EDT
Description of problem:

I recently upgraded Empathy v3.5.4.1-2.fc18 in Fedora 18(rawhide). When i try to
run(open) it, system gives me following error message:

empathy: error while loading shared libraries: libempathy-gtk-3.5.4.1.so:
cannot open shared object file: No such file or directory


Version-Release number of selected component (if applicable):
Empathy v3.5.4.1-2.fc18


How reproducible:
Always


Steps to Reproduce:
1.Go to command prompt
2.Enter "Empathy" on hit enter
3.
  
Actual results:
empathy: error while loading shared libraries: libempathy-gtk-3.5.4.1.so: cannot open shared object file: No such file or directory


Expected results:
Empathy should run successfully and open the main empathy window.


Additional info:
Comment 1 Brian Pepple 2012-08-12 17:03:10 EDT
*** Bug 847514 has been marked as a duplicate of this bug. ***
Comment 2 Elad Alfassa 2012-08-12 17:08:08 EDT
Marking as a F18Final blocker bug as per criteria:
 All applications listed under the Applications menu or category must start successfully



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Mathieu Bridon 2012-08-21 22:26:43 EDT
I've had this problem as well, and it isn't fixed by Empathy 3.5.5.

For some reason, Empathy doesn't find its libraries in /usr/lib*/empathy/, it only searches for them in /usr/lib*/

Adding the right symlinks makes Empathy work, but that's just a workaround, not a solution. (plus, it breaks at the next update if the sonames have been bumped)
Comment 4 Brian Pepple 2012-08-22 10:46:33 EDT

*** This bug has been marked as a duplicate of bug 849701 ***
Comment 5 Brian Pepple 2012-08-22 10:47:55 EDT
*** Bug 849701 has been marked as a duplicate of this bug. ***
Comment 6 Brian Pepple 2012-08-22 10:50:01 EDT
empathy-3.5.90 is out, and if that doesn't fix this, I'll dig into this once I get back from vacation.
Comment 7 Sebastian Keller 2012-08-22 19:13:58 EDT
I think the problem is that empathy ships libempathy & libempathy-gtk as public libraries in %{_libdir}/empathy now and the package removes the rpath.

Maybe something like what is already done in the gnome-shell package could be used here too:
http://pkgs.fedoraproject.org/cgit/gnome-shell.git/tree/gnome-shell.spec?id=311c497f7c4002a94af6f760832643ecbd748d64#n123
Comment 8 Nathaniel McCallum 2012-08-25 21:56:41 EDT
FYI:

$ empathy
empathy: error while loading shared libraries: libempathy-gtk-3.5.90.so: cannot open shared object file: No such file or directory
Comment 9 Debarshi Ray 2012-08-30 10:26:54 EDT
(In reply to comment #7)
> I think the problem is that empathy ships libempathy & libempathy-gtk as
> public libraries in %{_libdir}/empathy now and the package removes the rpath.

You are right. There is no need to delete the rpath in the package since it only points to %{_libdir}/empathy, and "%__arch_install_post /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot" is happy with it.

Building a new package with the fix now.
Comment 10 Debarshi Ray 2012-08-30 11:21:11 EDT
Should be fixed in empathy-3.5.90-3.fc18
Comment 11 Tim Flink 2012-11-30 13:45:00 EST
+1 final blocker due to violation of the following F18 final release criterion [1]:

All applications listed under the Applications menu or category must start successfully

[1] http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 12 Debarshi Ray 2012-11-30 14:08:07 EST
Fixed package is already in stable.

Note You need to log in before you can comment on or make changes to this bug.