This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 847514 - Empathy won't start on Fedora 18 branched "error while loading shared libraries: libempathy-gtk-3.5.5.so:"
Empathy won't start on Fedora 18 branched "error while loading shared librari...
Status: CLOSED DUPLICATE of bug 846908
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-08-12 09:20 EDT by Elad Alfassa
Modified: 2012-08-12 17:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-12 17:03:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Elad Alfassa 2012-08-12 09:20:34 EDT
Description of problem:
Empathy won't start, outputs this error message:

empathy: error while loading shared libraries: libempathy-gtk-3.5.5.so: cannot open shared object file: No such file or directory

[elad@alfmobile ~]$ locate libempathy
/usr/lib64/empathy/libempathy-3.5.5.so
/usr/lib64/empathy/libempathy-gtk-3.5.5.so
/usr/lib64/empathy/libempathy-gtk.so
/usr/lib64/empathy/libempathy.so

so the library is there, but it won't load.

[elad@alfmobile ~]$ rpm -q empathy
empathy-3.5.5-1.fc18.x86_64

[elad@alfmobile ~]$ strace empathy
execve("/usr/bin/empathy", ["empathy"], [/* 51 vars */]) = 0
brk(0)                                  = 0x230b000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd205c52000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=135712, ...}) = 0
mmap(NULL, 135712, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7fd205c30000
close(3)                                = 0
open("/lib64/tls/x86_64/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/lib64/tls/x86_64", 0x7fff71bb60d0) = -1 ENOENT (No such file or directory)
open("/lib64/tls/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/lib64/tls", {st_mode=S_IFDIR|0555, st_size=4096, ...}) = 0
open("/lib64/x86_64/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/lib64/x86_64", 0x7fff71bb60d0)   = -1 ENOENT (No such file or directory)
open("/lib64/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/lib64", {st_mode=S_IFDIR|0555, st_size=135168, ...}) = 0
open("/usr/lib64/tls/x86_64/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/tls/x86_64", 0x7fff71bb60d0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/tls/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/tls", {st_mode=S_IFDIR|0555, st_size=4096, ...}) = 0
open("/usr/lib64/x86_64/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/x86_64", 0x7fff71bb60d0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/libempathy-gtk-3.5.5.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib64", {st_mode=S_IFDIR|0555, st_size=135168, ...}) = 0
writev(2, [{"empathy", 7}, {": ", 2}, {"error while loading shared libra"..., 36}, {": ", 2}, {"libempathy-gtk-3.5.5.so", 23}, {": ", 2}, {"cannot open shared object file", 30}, {": ", 2}, {"No such file or directory", 25}, {"\n", 1}], 10empathy: error while loading shared libraries: libempathy-gtk-3.5.5.so: cannot open shared object file: No such file or directory
) = 130
exit_group(127)                         = ?
+++ exited with 127 +++



Marking as a F18Final blocker bug as per criteria:
 All applications listed under the Applications menu or category must start successfully
Comment 1 Brian Pepple 2012-08-12 17:03:10 EDT

*** This bug has been marked as a duplicate of bug 846908 ***

Note You need to log in before you can comment on or make changes to this bug.