Bug 847034 - SELinux is preventing /usr/bin/gxine from 'read' accesses on the directory /usr/lib/games.
SELinux is preventing /usr/bin/gxine from 'read' accesses on the directory /u...
Status: CLOSED DUPLICATE of bug 847031
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c6f72443bcd02881cb3ebae66f2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 09:49 EDT by drprcleary
Modified: 2012-08-10 02:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 02:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drprcleary 2012-08-09 09:49:26 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.i686
time:           Thu 09 Aug 2012 02:48:52 PM BST

description:
:SELinux is preventing /usr/bin/gxine from 'read' accesses on the directory /usr/lib/games.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gxine should be allowed read access on the games directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep pool /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:games_exec_t:s0
:Target Objects                /usr/lib/games [ dir ]
:Source                        pool
:Source Path                   /usr/bin/gxine
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gxine-0.5.907-2.fc17.i686
:Target RPM Packages           filesystem-3-2.fc17.i686
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.i686 #1 SMP Mon Jul 30
:                              15:41:00 UTC 2012 i686 i686
:Alert Count                   12
:First Seen                    Sat 04 Aug 2012 12:33:46 PM BST
:Last Seen                     Sun 05 Aug 2012 10:24:57 PM BST
:Local ID                      d4d07f7b-153e-47aa-9baf-34efe4ca6a2e
:
:Raw Audit Messages
:type=AVC msg=audit(1344201897.482:172): avc:  denied  { read } for  pid=13993 comm="pool" name="games" dev="dm-2" ino=136 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:games_exec_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1344201897.482:172): arch=i386 syscall=open success=no exit=EACCES a0=b5903498 a1=48000 a2=0 a3=0 items=0 ppid=1 pid=13993 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=pool exe=/usr/bin/gxine subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: pool,mozilla_plugin_t,games_exec_t,dir,read
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow mozilla_plugin_t games_exec_t:dir read;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow mozilla_plugin_t games_exec_t:dir read;
:
Comment 1 Miroslav Grepl 2012-08-10 02:09:43 EDT

*** This bug has been marked as a duplicate of bug 847031 ***

Note You need to log in before you can comment on or make changes to this bug.