Bug 847065 - User is asked to install spice cab file over and over again when accessing VM through User portal from IE under admin privileges
User is asked to install spice cab file over and over again when accessing VM...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-activex-win (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Uri Lublin
Desktop QE
spice
:
: 866601 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 10:57 EDT by Marian Krcmarik
Modified: 2016-02-10 15:20 EST (History)
17 users (show)

See Also:
Fixed In Version: spice-client-msi-3.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:49:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-08-09 10:57:50 EDT
Description of problem:
User is asked to install spice cab file over and over again when accessing VM through User portal from IE under admin privileges on clean Windows7 client machine. This problem seems to be related to USBClerk installation because If IE is not started under admin privileges which means no USBClerk instalaltion is started (due to missing privileges for the installation) The cab installation is done properly and next click on console button in admin portal opens spice session. On the other hand when IE is started under admin privileges and an user click on Console button, installation of USBClerk is started, done properly but next click on Console button prompts installation of SpiceX again (and so on in a Loop).
The workaround is to restart IE. This was not seen on WindowXp so looks like Wiondows7 specific.
I am not sure about the component may be the installer or SpiceX?

Version-Release number of selected component (if applicable):
rhevm-spice-client-x64-cab-3.1-4.el6.noarch.rpm in RHEVM3.1 (si13)

How reproducible:
Always

Steps to Reproduce:
1. Open User portal of RHEVM in Internet explorer uder Admin privileges (Run as Admin) from WIndows7 client without SpiceX previously installed.
2. Click on the Console button of any available VM to get SpiceX installed.
3. Go through installation of USBClerk.
4. Click again on Console button to get spice session.
  
Actual results:
User is asked for installation of SpiceX again even though It is already installed.

Expected results:
User gets spice session opened since SpiceX was installed already.

Additional info:
After restarting IE user is able to open spice session. Installation without admin privileges (without USBClerk installation) works properly.
Comment 1 Marc-Andre Lureau 2012-08-09 11:19:23 EDT
this might be because the activex is installed under UAC, not as admin. We may want to install it differently when installer is run as admin, but I am afriad this may create further issues (two versions installed)..
Comment 2 Marc-Andre Lureau 2012-08-09 11:25:11 EDT
lowering severity, this is minor annoyance only with Win7 as admin. Spice client should be used as regular user.
Comment 3 Marian Krcmarik 2012-08-09 11:31:57 EDT
(In reply to comment #2)
> lowering severity, this is minor annoyance only with Win7 as admin. Spice
> client should be used as regular user.

There is no other way how to get USBClerk installed on the client right now - only running IE under admin privileges.
If we have another way how to deploy USBClerk on clients - USBClerk standalone msi somehow distibuted then It may be minor annoyance otherwise I do not agree.
Comment 4 Uri Lublin 2012-10-25 12:06:32 EDT
(In reply to comment #3)
> There is no other way how to get USBClerk installed on the client right now
> - only running IE under admin privileges.

As part of virt-viewer installation, the usbclerk installer, usbclerk-setup.exe, is copied into virt-viewer directory. Administrators can run it to install usbclerk.
Comment 5 David Blechter 2012-11-21 12:39:59 EST
copied additional scenario from the bug that was closed as the dup of this one:

Scenario B: Legacy Client was installed prior to the test:
1. On a Windows client, that used RHEVM 3.0 w/spicec, bring up IE as admin
2. Navigate to the RHEVM User Portal and try to launch a console to a VM
Comment 6 David Blechter 2012-11-21 12:41:36 EST
*** Bug 866601 has been marked as a duplicate of this bug. ***
Comment 7 Dave Sullivan 2013-01-16 16:57:13 EST
I just went through this again, on my Windows 7 VM with IE9 there are delay waits in seeing the bottom of the screen "Install for all users" after you click the console, so need to be patient.  Also it took several iterations of going through this for it to work. I think the third time my spice console came up for me as a non admin user, for a customer with Windows based desktops using corporate IE this is rather painful.  I don't really think corporate environments have the luxury of just install firefox to get around this pain

Version-Release number of selected component (if applicable):
RHEV 3.1
rhevm-spice-client-x64-cab-3.1-8.el6.noarch
Windows 7

How reproducible:
100%

Steps to Reproduce:
From a fresh Windows 7 install with IE9, and using the webadmin portal:
- Create a 'Standard User'
- Login as the user, access the webadmin portal
- Start a VM with a SPICE console attached
- Attempt to access SPICE console
- Bar at bottom of screen "This website wants to install the following add-on: 'SpiceX.cab' from 'Red Hat, Inc.'."  - Select down arrow, and "Install for All Users".
- Webadmin refreshes
- Attempt to access SPICE console again
- Password prompt for 'admin' user
- usbclerk setup starts, click through and install -> NOTHING
- Attempt to access SPICE console AGAIN
- Bar at bottom of screen "This website wants to install the following add-on: 'SpiceX.cab' from 'Red Hat, Inc.'."  - Select down arrow, and "Install for All Users".   AGAIN
- Webadmin refreshes
- Attempt to access SPICE console again
- Password prompt for 'admin' user
- usbclerk setup starts, click through and install, except it removes the previously installed usbclerk...
- No SPICE console still...

So;

- Attempt to access SPICE console another time
- Bar at bottom of screen "This website wants to install the following add-on: 'SpiceX.cab' from 'Red Hat, Inc.'." - Select normal 'Install' option
- Get "Internet Explorer Add-on Installer - Security Warning
- Click [Install]
- Notice error message:
VirtViewer 0.5.3 Setup
----------------------
Note: usbclerk is not installed. Admin permissions are required
                                                     [   OK   ]

- Click [OK]
- Remote Viewer/SPICE Console appears

- Restart IE
- Attempt SPICE console again
- It works
  
Actual results:
As described above, frustration, plugin not really installed for all users as well.

Expected results:

- Install for all users to install for all users out of the box and work with how IE9 expects plugins that use this functionality to work.
- Experience to better match the expectations set by the documentation such as 
 https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Virtualization/3.1/html/User_Portal_Guide/User_Guide-Getting_Started-Install_SPICE_Plugin.html
Comment 8 Jiri Belka 2013-04-11 10:21:29 EDT
Able to reproduced on SF13.
Comment 27 Marc-Andre Lureau 2013-07-15 09:04:37 EDT
mingw-virt-viewer will no longer ship the activex, moving to appropriate component
Comment 28 Uri Lublin 2013-08-11 09:34:59 EDT
This bug is "fixed" by the new rhevm-spice-client 3.3-2 build.
BUT if one first run-as admin, and later run as a regular user, the first time (as admin) it works the second time (as user) it does not, as spice-x is installed for all and virt-viewer is installed only for admin users.

Can we ask users to not run Internet-Explorer as Administrator ?
That does not make sense since virt-viewer in the cab is installed per-user.
If per-machine install is required the (new) msi should be used.

A similar problem may happen when "install for all users" is used.
Comment 30 Bill Sanford 2013-12-11 15:15:52 EST
Verified with RHEV-M 3.3 (is26)
Comment 32 errata-xmlrpc 2014-01-21 09:49:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0050.html

Note You need to log in before you can comment on or make changes to this bug.