Bug 866601 - RHEV Client: Running IE as admin, user cannot use virt-viewer
RHEV Client: Running IE as admin, user cannot use virt-viewer
Status: CLOSED DUPLICATE of bug 847065
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-activex-win (Show other bugs)
3.1.0
x86_64 Windows
unspecified Severity high
: ---
: ---
Assigned To: Arnon Gilboa
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 13:28 EDT by Vimal Patel
Modified: 2012-11-21 12:41 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-21 12:41:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2012-10-15 13:28:55 EDT
Description of problem:
If the user never had the spicec client, going to the user portal and running IE as an admin, it will keep prompting/re-prompting for the installation of ActiveX even though it is already installed, and the user will never be able to bring up remote-viewer if IE is run as an administrator.

If the user had spicec client, and going to the user portal and running IE as an admin, it will prompt the first time for the ActiveX installation, but after that it will not and you can go to the console, but it will come up with spicec client.  This seems like strange behavior after the user believed they just upgraded from spicec of 3.0 to remote-viewer of 3.1

*Tested on RHEV-M 3.1, using a Windows 7 client.

Version-Release number of selected component (if applicable):
RHEV-M 3.1, si20

How reproducible:
100%

Scenario A: No legacy client
Steps to Reproduce:
1. On a clean Windows client, bring up IE as admin
2. Navigate to the RHEVM User Portal and try to launch a console to a VM

Scenario B: Legacy Client
1. On a Windows client, that used RHEVM 3.0 w/spicec, bring up IE as admin
2. Navigate to the RHEVM User Portal and try to launch a console to a VM
  
Actual results:
Cannot bring up a console with IE run as admin, or the legacy spicec console is brought up.

Expected results:
Remote-viewer the new client is brought up.

Additional info:
Comment 1 David Jaša 2012-11-08 13:13:32 EST
Vimal, isn't it duplicate of bug 847065? In any case, I didn't see any of these in the recent (beta3 and later builds) so I see them as candidates for CURRENTRELEASE.
Comment 2 David Blechter 2012-11-20 15:03:53 EST
Vimal, can you confirm the comment 1?
Comment 3 Vimal Patel 2012-11-20 15:36:39 EST
Yes, I agree with David Jasa that it is a DUP of 847065.  The only comment that isn't in 847065 is that if the legacy spicec client is already installed that will come up instead of remote-viewer, which is really unexpected behavior (Screnario B described above), but that can be added as a comment to 847065.
Comment 4 David Blechter 2012-11-21 12:41:36 EST

*** This bug has been marked as a duplicate of bug 847065 ***

Note You need to log in before you can comment on or make changes to this bug.