Bug 847105 - [abrt] yum-utils-1.1.31-6.fc18: progress.py:529:_do_update_meter:IndexError: list index out of range
[abrt] yum-utils-1.1.31-6.fc18: progress.py:529:_do_update_meter:IndexError: ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-urlgrabber (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:41393a575d5ee880dd0ec7246dc...
:
: 847342 847450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 13:55 EDT by Sandro Mani
Modified: 2014-01-21 18:23 EST (History)
7 users (show)

See Also:
Fixed In Version: python-urlgrabber-3.9.1-17.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 23:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.53 KB, text/plain)
2012-08-09 13:55 EDT, Sandro Mani
no flags Details

  None (edit)
Description Sandro Mani 2012-08-09 13:55:21 EDT
Description of problem:
I simply wrote
yumdownloader --source gwenview


Version-Release number of selected component:
yum-utils-1.1.31-6.fc18

Additional info:
libreport version: 2.0.12
abrt_version:   2.0.11
cmdline:        /usr/bin/python /usr/bin/yumdownloader --source gwenview
kernel:         3.6.0-0.rc1.git0.2.fc18.x86_64

backtrace:
:progress.py:529:_do_update_meter:IndexError: list index out of range
:
:Traceback (most recent call last):
:  File "/usr/bin/yumdownloader", line 335, in <module>
:    util = YumDownloader()
:  File "/usr/bin/yumdownloader", line 73, in __init__
:    self.main()
:  File "/usr/bin/yumdownloader", line 96, in main
:    self.doUtilYumSetup(opts)
:  File "/usr/bin/yumdownloader", line 294, in doUtilYumSetup
:    self._getRepos(doSetup = True)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 720, in _getRepos
:    self._repos.doSetup(thisrepo)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 127, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 96, in retrieveAllMD
:    urlgrabber.grabber.parallel_wait()
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2208, in parallel_wait
:    perform()
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2151, in perform
:    for opts, size, ug_err in dl.perform():
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2094, in perform
:    done = self.running[fd].perform()
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2051, in perform
:    self.running[_id].progress_obj.update(size)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 141, in update
:    self._do_update(amount_read, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 328, in _do_update
:    self.master.update_meter(self, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 431, in update_meter
:    self._do_update_meter(meter, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 529, in _do_update_meter
:    meter = self.meters[self.index]
:IndexError: list index out of range
:
:Local variables in innermost frame:
:rt: 0.2647460855520364
:frac: 0.9664693055169128
:fdd: '16 MB'
:format: 'files: %3i/%-3i %3i%%   data: %6.6s/%-6.6s %3i%%   time: %8.8s/%8.8s'
:df: 2
:tt: 6.1264151491201515
:meter: <urlgrabber.progress.MultiFileHelper instance at 0x2ed0ea8>
:ave_dl: '2.2 M'
:self: <urlgrabber.progress.TextMultiFileMeter instance at 0x2ed0368>
:ftt: '00:00:06'
:dd: 17211992
:fdt: '00:00:05'
:pd: 97.13693055169128
:tf: 3
:pf: 67.15666666666667
:dt: 5.861669063568115
:now: 1344534767.539305
:td: 17809145
:ftd: '17 MB'
Comment 1 Sandro Mani 2012-08-09 13:55:24 EDT
Created attachment 603318 [details]
File: core_backtrace
Comment 2 Zdeněk Pavlas 2012-08-10 04:30:14 EDT
A stupid bug I've commited 2 days ago.  Thanks for spotting this early!  Fixed in python-urlgrabber-3.9.1-17.fc18
Comment 3 Fedora Update System 2012-08-10 04:42:14 EDT
python-urlgrabber-3.9.1-16.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-urlgrabber-3.9.1-16.fc17
Comment 4 Fedora Update System 2012-08-10 18:38:06 EDT
Package python-urlgrabber-3.9.1-16.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-urlgrabber-3.9.1-16.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11742/python-urlgrabber-3.9.1-16.fc17
then log in and leave karma (feedback).
Comment 5 Zdeněk Pavlas 2012-08-15 03:48:48 EDT
*** Bug 847450 has been marked as a duplicate of this bug. ***
Comment 6 Zdeněk Pavlas 2012-08-15 10:29:31 EDT
*** Bug 847342 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2012-08-24 23:01:52 EDT
python-urlgrabber-3.9.1-16.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.