Bug 847450 - [abrt] yum-3.4.3-28.fc17: progress.py:529:_do_update_meter:IndexError: list index out of range
[abrt] yum-3.4.3-28.fc17: progress.py:529:_do_update_meter:IndexError: list i...
Status: CLOSED DUPLICATE of bug 847105
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:41393a575d5ee880dd0ec7246dc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 09:03 EDT by Gino
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 03:48:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (2.23 KB, text/plain)
2012-08-11 09:03 EDT, Gino
no flags Details

  None (edit)
Description Gino 2012-08-11 09:03:29 EDT
Description of problem:


Version-Release number of selected component:
yum-3.4.3-28.fc17

Additional info:
libreport version: 2.0.12
abrt_version:   2.0.11
cmdline:        /usr/bin/python /usr/bin/yum upgrade --skip-broken --exclude=ruby-irb
kernel:         3.5.0-2.fc17.i686.PAE

backtrace:
:progress.py:529:_do_update_meter:IndexError: list index out of range
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 319, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 144, in main
:    result, resultmsgs = base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/yumcommands.py", line 1464, in doCommand
:    return base.updatePkgs(extcmds, update_to=(basecmd == 'upgrade-to'))
:  File "/usr/share/yum-cli/cli.py", line 890, in updatePkgs
:    self.update()
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 4364, in update
:    updates = self.up.getUpdatesTuples()
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1032, in <lambda>
:    up = property(fget=lambda self: self._getUpdates(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 837, in _getUpdates
:    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 777, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 302, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 127, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 96, in retrieveAllMD
:    urlgrabber.grabber.parallel_wait()
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2208, in parallel_wait
:    perform()
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2151, in perform
:    for opts, size, ug_err in dl.perform():
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2094, in perform
:    done = self.running[fd].perform()
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2051, in perform
:    self.running[_id].progress_obj.update(size)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 141, in update
:    self._do_update(amount_read, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 328, in _do_update
:    self.master.update_meter(self, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 431, in update_meter
:    self._do_update_meter(meter, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 529, in _do_update_meter
:    meter = self.meters[self.index]
:IndexError: list index out of range
:
:Local variables in innermost frame:
:rt: -1.066432702681669
:frac: 1.922175303655461
:fdd: '389 kB'
:format: 'files: %3i/%-3i %3i%%   data: %6.6s/%-6.6s %3i%%   time: %8.8s/%8.8s'
:df: 3
:tt: 1.145016205170504
:meter: <urlgrabber.progress.MultiFileHelper instance at 0xa0db3cc>
:ave_dl: '175 k'
:self: <urlgrabber.progress.TextMultiFileMeter instance at 0x9e92d2c>
:ftt: '00:00:01'
:dd: 397848
:fdt: '00:00:02'
:pd: 192.70753036554612
:tf: 5
:pf: 60.49
:dt: 2.211448907852173
:now: 1344690173.864259
:td: 206978
:ftd: '202 kB'
Comment 1 Gino 2012-08-11 09:03:32 EDT
Created attachment 603683 [details]
File: core_backtrace
Comment 2 Zdeněk Pavlas 2012-08-15 03:48:48 EDT

*** This bug has been marked as a duplicate of bug 847105 ***

Note You need to log in before you can comment on or make changes to this bug.