Bug 847205 - [virtio-win][scsi] BSOD when restarting guest with data scsi disk after S4/S3
[virtio-win][scsi] BSOD when restarting guest with data scsi disk after S4/S3
Status: CLOSED DUPLICATE of bug 846912
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
:
Depends On:
Blocks: 761491 912287
  Show dependency treegraph
 
Reported: 2012-08-10 01:32 EDT by dawu
Modified: 2013-03-14 11:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 11:33:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eventLog-system.evtx (1.07 MB, application/octet-stream)
2012-08-10 02:49 EDT, dawu
no flags Details

  None (edit)
Description dawu 2012-08-10 01:32:50 EDT
Description of problem:
after S4/S3,restart guest with data scsi disk, guest will stuck during shutting down for a long time and final often BSOD with 9F code, sometimes, it can restart with windows error prompt in guest "Windows has recovered from an unexpected shutdown".

Version-Release number of selected component (if applicable):
kernel-2.6.32-294.el6.x86_64
qemu-kvm-0.12.1.2-2.302.el6.x86_64
virtio-win-prewhql-32


How reproducible:
always

Steps to Reproduce:
1. Start guest with data scsi disk:
   /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu Penryn,+x2apic,family=0xf -usb -device usb-tablet -drive file=win7-64-new.qcow2,format=qcow2,index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,werror=stop,aio=native,serial=testefsfsfer -device virtio-scsi-pci,id=bus0 -device scsi-hd,bus=bus0.0,drive=drive-virtio-disk1,id=virtio-disk1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup0 -device e1000,netdev=hostnet0,mac=00:10:16:23:25:12,bus=pci.0,addr=0x4 -uuid 175b476d-ac95-48aa-8c9c-a914171290c5 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -monitor stdio -name win7-64-scsi-new -spice disable-ticketing,port=5931 -vga qxl -qmp tcp:0:4444,server,nowait  -bios /usr/share/seabios/bios-pm.bin -device virtio-scsi-pci,bus=pci.0,id=scsi0 -drive file=test2.qcow2,format=qcow2,if=none,media=disk,cache=none,werror=stop,aio=native,id=scsi0,serial=dfwfwefsfsdf-data -device scsi-hd,bus=scsi0.0,drive=scsi0,id=scsi1

2. S4/S3

3. Resume from S4/S3 and login guest

4. Restart guest 
  
Actual results:
Guest stuck during shutting down for a long time and final often BSOD with 9F code, sometimes, it can restart with windows error prompt in guest "Windows has recovered from an unexpected shutdown",following is the problem details for this error:
-------------------------------------------------------------------------------
Problem signature:
  Problem Event Name:	BlueScreen
  OS Version:	6.1.7601.2.1.0.256.1
  Locale ID:	1033

Additional information about the problem:
  BCCode:	1000009f
  BCP1:	0000000000000004
  BCP2:	0000000000000258
  BCP3:	FFFFFA80018E8B60
  BCP4:	FFFFF80003C66510
  OS Version:	6_1_7601
  Service Pack:	1_0
  Product:	256_1

Files that help describe the problem:
  C:\Windows\Minidump\081012-11812-01.dmp
  C:\Users\dawu\AppData\Local\Temp\WER-21078-0.sysdata.xml

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
-------------------------------------------------------------------------------
For more details,please refer to the windows event log file for system in the attached "eventLog-system.evtx"

Expected results:
Guest should restart successfully without any error.

Additional info:
Comment 1 dawu 2012-08-10 01:35:07 EDT
This issue does not exist in guest without data scsi disk, dump file will provide later.

Best Regards,
Dawn
Comment 4 dawu 2012-08-10 02:49:36 EDT
Created attachment 603431 [details]
eventLog-system.evtx
Comment 7 Gal Hammer 2013-03-11 08:09:47 EDT
Hi Dawn,

Could be that this is related to bz#846912? Does the new SeaBIOS works for this one as well?

Thanks, Gal.
Comment 8 dawu 2013-03-11 23:02:29 EDT
(In reply to comment #7)
> Hi Dawn,
> 
> Could be that this is related to bz#846912? Does the new SeaBIOS works for
> this one as well?
> 
> Thanks, Gal.

Hi Gal,
Yes, it should be related to bz#846912, try to with the new SeaBIOS from https://bugzilla.redhat.com/show_bug.cgi?id=912561, this issue gone.

Thanks for your reminder.

Best Regards,
Dawn
Comment 9 Gal Hammer 2013-03-14 11:33:01 EDT

*** This bug has been marked as a duplicate of bug 846912 ***

Note You need to log in before you can comment on or make changes to this bug.