Bug 912561 - Disabling/enabling scsi driver stuck after S3/S4
Summary: Disabling/enabling scsi driver stuck after S3/S4
Status: CLOSED DUPLICATE of bug 846912
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: seabios (Show other bugs)
(Show other bugs)
Version: 6.4
Hardware: Unspecified Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On: 846912 969808 969809
Blocks: 761491 896495 912287
TreeView+ depends on / blocked
 
Reported: 2013-02-19 02:20 UTC by Mike Cao
Modified: 2018-12-01 17:41 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 846912
Environment:
Last Closed: 2013-03-12 15:16:50 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SeaBIOS binary including the backport (128.00 KB, application/octet-stream)
2013-02-20 11:53 UTC, Paolo Bonzini
no flags Details

Comment 3 Paolo Bonzini 2013-02-20 11:53:48 UTC
Created attachment 699975 [details]
SeaBIOS binary including the backport

Hi, please test this binary.  You can use "-bios /path/to/bios.bin" to pick the right BIOS file from the attachment.

Comment 4 RHEL Product and Program Management 2013-02-24 06:47:15 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 6 Ronen Hod 2013-02-26 18:17:50 UTC
Mike,

Did you happen to test this bug fix?
Since it is a "generic" fix, I would like to ask that you retest all of the 9F bugs, since it might fix some other bugs too.
https://bugzilla.redhat.com/show_bug.cgi?id=896495

Thanks, Ronen.

Comment 8 Mike Cao 2013-02-27 08:10:34 UTC
(In reply to comment #6)
> Mike,
> 
> Did you happen to test this bug fix?

Sure ,Next week I promise :)
> Since it is a "generic" fix, I would like to ask that you retest all of the
> 9F bugs, since it might fix some other bugs too.
> https://bugzilla.redhat.com/show_bug.cgi?id=896495
> 
> Thanks, Ronen.

Comment 9 Mike Cao 2013-03-04 08:42:27 UTC
copy from the original bug :

dawu@redhat.com 2013-03-04 14:10:13 CST

Verify this issue with the fixed seabios on upstream, https://bugzilla.redhat.com/attachment.cgi?id=699975, still hit this issue, following is the details:

environment:
kernel-2.6.32-361.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.356.el6.x86_64
virtio-win-prewhql-54

steps:
1. replace the current bios.bin to the fixed one from upstream, https://bugzilla.redhat.com/attachment.cgi?id=699975

2. Start guest with CLI:
   /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu Penryn,+x2apic,family=0xf -usb -device usb-tablet -drive file=win7-64-fun.qcow2,format=qcow2,index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,werror=stop,aio=native -device virtio-scsi-pci,id=bus0 -device scsi-hd,bus=bus0.0,drive=drive-virtio-disk1,id=virtio-disk1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=00:10:16:23:25:16,bus=pci.0,addr=0x4 -uuid dbde9e26-140c-4efb-8d58-4b1ca0251cdb -rtc base=localtime -no-kvm-pit-reinjection -monitor stdio -name win7-64-scsi -spice disable-ticketing,port=5931 -vga qxl -qmp tcp:0:4445,server,nowait -device virtio-scsi-pci,bus=pci.0,id=scsi0 -drive file=disk1.qcow2,format=qcow2,if=none,media=disk,aio=native,werror=stop,rerror=stop,id=scsi0 -device scsi-hd,bus=scsi0.0,drive=scsi0,id=scsi1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0

3. Do S3 for guest
4. Disable scsi driver after resume finish.

Actually result:
guest hang when disabling scsi driver.


Best Regards,
Dawn

Comment 11 Mike Cao 2013-03-11 08:06:41 UTC
(In reply to comment #3)
> Created attachment 699975 [details]
> SeaBIOS binary including the backport
> 
> Hi, please test this binary.  You can use "-bios /path/to/bios.bin" to pick
> the right BIOS file from the attachment.

Hi, Paolo

you patch only fix https://bugzilla.redhat.com/show_bug.cgi?id=846519 .
When do you make the official seabios build ?

Thanks,
Mike

Comment 12 Paolo Bonzini 2013-03-11 15:09:06 UTC
I'll post the patch soon, in the meanwhile I've assigned bug 846519 to myself.

Comment 13 Mike Cao 2013-03-12 07:07:33 UTC
*** Bug 846519 has been marked as a duplicate of this bug. ***

Comment 14 Mike Cao 2013-03-12 07:09:12 UTC
*** Bug 846533 has been marked as a duplicate of this bug. ***

Comment 15 Paolo Bonzini 2013-03-12 15:16:50 UTC
Closing the issue since the other BZ has test results from QE and an attached customer case.

*** This bug has been marked as a duplicate of bug 846912 ***

Comment 16 Mike Cao 2013-03-15 09:37:22 UTC
(In reply to comment #9)
> copy from the original bug :
> 
> dawu@redhat.com 2013-03-04 14:10:13 CST
> 
> Verify this issue with the fixed seabios on upstream,
> https://bugzilla.redhat.com/attachment.cgi?id=699975, still hit this issue,
> following is the details:
> 
> environment:
> kernel-2.6.32-361.el6.x86_64
> qemu-kvm-rhev-0.12.1.2-2.356.el6.x86_64
> virtio-win-prewhql-54
> 
> steps:
> 1. replace the current bios.bin to the fixed one from upstream,
> https://bugzilla.redhat.com/attachment.cgi?id=699975
> 
> 2. Start guest with CLI:
>    /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu Penryn,+x2apic,family=0xf -usb
> -device usb-tablet -drive
> file=win7-64-fun.qcow2,format=qcow2,index=0,if=none,id=drive-virtio-disk1,
> media=disk,cache=none,werror=stop,aio=native -device virtio-scsi-pci,id=bus0
> -device scsi-hd,bus=bus0.0,drive=drive-virtio-disk1,id=virtio-disk1 -netdev
> tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device
> e1000,netdev=hostnet0,mac=00:10:16:23:25:16,bus=pci.0,addr=0x4 -uuid
> dbde9e26-140c-4efb-8d58-4b1ca0251cdb -rtc base=localtime
> -no-kvm-pit-reinjection -monitor stdio -name win7-64-scsi -spice
> disable-ticketing,port=5931 -vga qxl -qmp tcp:0:4445,server,nowait -device
> virtio-scsi-pci,bus=pci.0,id=scsi0 -drive
> file=disk1.qcow2,format=qcow2,if=none,media=disk,aio=native,werror=stop,
> rerror=stop,id=scsi0 -device scsi-hd,bus=scsi0.0,drive=scsi0,id=scsi1
> -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0
> 
> 3. Do S3 for guest
> 4. Disable scsi driver after resume finish.
> 
> Actually result:
> guest hang when disabling scsi driver.
> 
> 
> Best Regards,
> Dawn

Pls ignore this comment .
According to https://bugzilla.redhat.com/show_bug.cgi?id=846912#c18 ,it has been fixed


Note You need to log in before you can comment on or make changes to this bug.