Bug 847273 - [abrt] gimp-2.8.0-1.fc17: gimp_tag_get_name: Process /usr/bin/gimp-2.8 was killed by signal 11 (SIGSEGV)
[abrt] gimp-2.8.0-1.fc17: gimp_tag_get_name: Process /usr/bin/gimp-2.8 was ki...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
abrt_hash:c3cd0ab3a45fdca4746eea8024a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 07:28 EDT by Tommi Pakarinen
Modified: 2013-03-26 18:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 10:55:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.73 KB, text/plain)
2012-08-10 07:28 EDT, Tommi Pakarinen
no flags Details
File: maps (79.72 KB, text/plain)
2012-08-10 07:28 EDT, Tommi Pakarinen
no flags Details
File: dso_list (9.43 KB, text/plain)
2012-08-10 07:28 EDT, Tommi Pakarinen
no flags Details

  None (edit)
Description Tommi Pakarinen 2012-08-10 07:28:42 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        gimp-2.8 /home/USERNAME/Pictures/P8090009.JPG
comment:        selected different brush palette
crash_function: gimp_tag_get_name
executable:     /usr/bin/gimp-2.8
kernel:         3.5.0-2.fc17.x86_64
pid:            1635
remote_result:  844014
time:           pe 10. elokuuta 2012 14.19.50
uid:            1000
username:       cpt2t2p

backtrace:      Text file, 39661 bytes
dso_list:       Text file, 9657 bytes
maps:           Text file, 81629 bytes

build_ids:
:fd3b4b06b698fed8a4803cb4e7d1e5b153f36c79
:f69712fe393313f44607679e934bf5a67f39ec50
:648ec22fc1014c2997277d04192463295520c336
:47e9c30fbf1ceba57da3125298f5b6f16ff27bfa
:b262a361763f91cca5e5826440bebaa4bc8cfebe
:a8efbe1d263ad42afae74bc027eee88eaa754f55
:75cde31c2277e9d7622007951c61110ce70e0650
:fc496e1f6fad45b22782332ccd3d41cfb17fdb66
:fd952473da735f9c0f50de231aa3d84d7855ef57
:e2f8ba3db2c86456528fe1f09829c62263d0fdee
:07925081fe15ff3427a4eaa12bc47cf2b0fa7233
:6880802db4dbe99bf291c5ca4e33a98ed02059fe
:3e15b85f52ae4725228209add374f1bf45a404ef
:6668de624a10d486a3484d5b4921f87b1e77d36c
:fb86c3a448f22bd68843d5aa0b35e74d20629e85
:8f7c190397d7c1f617e66f18f759714662b60367
:9d49f2f604fdc7a787f63c16cc08353956f2fd41
:588ae7cfb716316f54d1b4fd3878a034eefad073
:63651cdc0224824a9c9324c77c3b5887378e871d
:c4ec0971b2dcee71aaf8374975474054245fea00
:3596e33b33a0ac83e7c3218b687e1458c7765225
:822e9b3523e8312240f41a25722d539bc77ed436
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5
:6e5d5649c704cd3a34cf145ccd2d08994f1e83ff
:f4d479614b09460085428bbe7d53df454d0d39e5
:d804f8ee47797da9213a92f00cd095ecada8d79f
:e03c3b34aea57f34b2ab8bc259fe203d1fd9aa49
:4b044fe80e4c1b69986abc4b160c303048005d4e
:1ec2a7bb430f6ec982e05dce422ee2ad7ca535af
:6088efab2ef3571c51fb041bb70b4ab626221ba4
:45b9c1436f78151fc2e3f8ab1189d31532b2f2af
:2f721de911d84ad80f7b078c1c76228e9638e4ed
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881
:e269301fafc421669fee7a6244f5ba29429faa7f
:6086bff484a49cc8b80cb714d7e83a6391394800
:5b4f3d35b4612be98f2bbb635b3eabf0ee7e437d
:5a6c563ddb82460514d0bef2c3765cdfed62b9e3
:2b8776fb49966e9264207e9acb4bcb3a5fc21e3c
:87712be648d2d43ea4cd002fe7a859df636f1e13
:253afe744466fe7580bbb6040de6183dba9e2b02
:42675a8ad8f70ff19362070510cdf1ba202a70db
:b26a3acffde6a14576fe8b9bb2b73ff461f310b6
:396fda5abd0de2132396c4a3e94f7a7173bc26e7
:839c8e3a55bd7f61afdcfebeae52f9dadc3a69fb
:ce246b3297de0d233ac2c5f9e50061e2b13a330c
:999c6a40954a490f10496b3a9aac8346fbfd7e92
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:ec87953f655fbcbcbe71b591db5451e56739576e
:84ab9ba5e99929be54f3e866b4711951dd609b2e
:faca16f15d87b83d2947a386e319b02f724dcbb5
:ae443e3506ed7bc12b1adfc79e73da33725cc241
:0e1267a4d81de05f053eeed7f2f61fb46cda9e7c
:e45258c755689bf1d66580f1c9a3f9d4d3f26235
:3bbeb82b3bc850005dc0f186e15b20b45df0cbaa
:8debe4568c941cf553d60c38ee89e2c5275d003a
:f3d061fed5acb5641309f0fbb52b228723b850b6
:5d08d928a5f0b7efa48e4874b6dc4337d0a5ffb1
:b8bfc491895389962d926fdc99cbfbac571f2cf0
:620e023eead4fb71ea351dd9e72127b5052a432d
:404cbecd24d186758ed474b345313da28b2990fa
:3f0991d9a4679b6bdd8a78ab2d05ecf4cc995651
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480
:029268fba075445cf89f9991e92fc6f6ef906293
:7c35310fc506498c612d5d982ab03becc4b4817c
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:c61e487cc8906c4f1bd85b39a4d751b414e423a0
:67792c148d2b8f13f6732c9367e926c26d7376c5
:a005847a3d4e9fd30ba42de48c500a3c19c48ec4
:617e70e4105dfaa44b8d1f53b914e37eb5886ceb
:8c083e0f61deb55917e5c7b193fe4d000a7375f1
:247132297f287226a24c12e683292f5c94013066
:8c82bf8c637cca50c18798f2e93f195b4ab0ce78
:1a25eefe05ad238ff2f3c53d6811c633ac87c3eb
:23d1440088fed14354e355ac2cbdba1f38fcf1a3
:30dcd9b8ed918d4a36d11e3822dd23882c9ed403
:79aee4375d1f48c032b56a6a0a9c15b3773b030e
:b277af36744327e3d58eae76bcdaadcca71a28c6
:f4c064df8745dff15466d705fb049138f9a5c949
:508cf66f72e70054a41215f80ed2385c6bb80030
:516204cfc31148538d56b21e2f1b945ed50127d4
:b21a906e3576fa97597a721d955e42063a8569fe
:a553a7e9625a224a8f39286909adc17787ad51bd
:a966d087bd452eee811ee7d2f4b564d30c11db5a
:cc674b499a7c6bb57b082e82875eb092dea5a046
:567274f50c868c4079c57085e642176f06b8ec1c
:9e6594e38d36f94f5e02c90731970f1c72396147
:234d4eb1aa690c38533ef82f517b390255d3bc4d
:c24fd7404668fdbb57aec685a0f63cdd8a289d29
:54a5cc118d928470da13565de8592b664a9868e0
:51541a56cd9a38f97340ce7300c8cf724a67b919
:439d7f8b0a1203edcb16f8a355b33af73aca576b
:af555d6861942219baf9f10980a3aa138e7ba8c7
:a5cf7008c28585406297cf76ce11e2e554e5a7b4
:5bf8427ddeff24a2bd36962f68e6af6ffe14970f
:726a299098b7695fc69d788f6b19468810c1ba6e
:5350b5972464f66f404861dc50225a114a2a5e7e

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/cpt2t2p/2

core_backtrace:
:fd3b4b06b698fed8a4803cb4e7d1e5b153f36c79 0x36b9e6 gimp_tag_get_name [pie] -
:fd3b4b06b698fed8a4803cb4e7d1e5b153f36c79 0x245c09 - [pie] -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14db4c - libgtk-x11-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x206d8 - libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x282a7 g_signal_emit_valist libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x2815ae - libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14bf90 gtk_main_do_event libgtk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x4555c - libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x45503 - libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x400d7 - libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x42458 gdk_window_process_all_updates libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x424b9 - libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x1eb97 - libgdk-x11-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47dc2 g_main_loop_run libglib-2.0.so.0 -
:fd3b4b06b698fed8a4803cb4e7d1e5b153f36c79 0xb8e98 app_run [pie] -
:fd3b4b06b698fed8a4803cb4e7d1e5b153f36c79 0xb8946 main [pie] -

environ:
:_=*1121*/usr/bin/gnome-session
:CCACHE_HASHDIR=
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-nNlmNAV3NZ,guid=2d11617c68ea3c2602d9c93000000021
:DESKTOP_SESSION=gnome
:DISPLAY=:0.0
:GDMSESSION=gnome
:GDM_LANG=en_US.utf8
:GNOME_KEYRING_CONTROL=/run/user/USERNAME/keyring-OWsX9n
:GNOME_KEYRING_PID=1157
:HISTCONTROL=ignoredups
:HISTSIZE=1000
:HOME=/home/USERNAME
:HOSTNAME=HOSTNAME
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:IMSETTINGS_MODULE=none
:KDEDIRS=/usr
:KDE_IS_PRELINKED=1
:LANG=en_US.utf8
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:LOADEDMODULES=
:LOGNAME=USERNAME
:MAIL=/var/spool/mail/USERNAME
:MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles
:MODULESHOME=/usr/share/Modules
:NXDIR=/usr/NX
:PATH=/usr/lib64/qt-3.3/bin:/usr/NX/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:PWD=/home/USERNAME
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:QTLIB=/usr/lib64/qt-3.3/lib
:QT_GRAPHICSSYSTEM_CHECKED=1
:QT_IM_MODULE=xim
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
:SHELL=/bin/ksh
:SHLVL=1
:TERM=dumb
:USER=USERNAME
:USERNAME=USERNAME
:WINDOWPATH=1
:XAUTHORITY=/var/run/gdm/auth-for-USERNAME-5f91oO/database
:XDG_RUNTIME_DIR=/run/user/USERNAME
:XDG_SEAT=seat0
:XDG_SESSION_COOKIE=3348a5c6683ed24c9f5419370000000d-1344597307.136494-299555054
:XDG_SESSION_ID=2
:XDG_VTNR=1
:XMODIFIERS=@im=none
:'_AST_FEATURES=UNIVERSE - ucb'
:'A__z=\"*SHLVL'
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1161,unix/unix:/tmp/.ICE-unix/1161
:SSH_AUTH_SOCK=/run/user/USERNAME/keyring-OWsX9n/ssh
:GPG_AGENT_INFO=/run/user/USERNAME/keyring-OWsX9n/gpg:0:1
:LC_TIME=fi_FI.utf8
:LC_NUMERIC=fi_FI.utf8
:LC_MONETARY=fi_FI.utf8
:LC_MEASUREMENT=fi_FI.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gimp.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1635
:INSIDE_NAUTILUS_PYTHON=
:DESKTOP_STARTUP_ID=gthumb-1625-HOSTNAME-gimp-2.8-0_TIME102216

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 125999               processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       125999               125999               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/USERNAME/.xsession-errors
:pos:	3852
:flags:	0102002
:2:/home/USERNAME/.xsession-errors
:pos:	3852
:flags:	0102002
:3:socket:[23903]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[23905]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[23908]
:pos:	0
:flags:	02004002
:8:anon_inode:inotify
:pos:	0
:flags:	02004000
:9:pipe:[25790]
:pos:	0
:flags:	00
:10:socket:[26181]
:pos:	0
:flags:	02004002

var_log_messages:
:Aug 10 14:19:50 i7-2700k kernel: [  317.537985] gimp-2.8[1635]: segfault at 2 ip 00007f9af92eb9e6 sp 00007fffc078aec0 error 4 in gimp-2.8[7f9af8f80000+580000]
:Aug 10 14:19:52 i7-2700k abrt[1873]: Saved core dump of pid 1635 (/usr/bin/gimp-2.8) to /var/spool/abrt/ccpp-2012-08-10-14:19:50-1635 (363384832 bytes)
Comment 1 Tommi Pakarinen 2012-08-10 07:28:47 EDT
Created attachment 603479 [details]
File: backtrace
Comment 2 Tommi Pakarinen 2012-08-10 07:28:49 EDT
Created attachment 603480 [details]
File: maps
Comment 3 Tommi Pakarinen 2012-08-10 07:28:52 EDT
Created attachment 603481 [details]
File: dso_list
Comment 4 Nils Philippsen 2012-11-06 11:49:54 EST
Sorry for taking so long. I can't reproduce this with gimp-2.8.2, do you still see this issue? Thanks.
Comment 5 Tommi Pakarinen 2012-11-11 17:27:23 EST
(In reply to comment #4)
> Sorry for taking so long. I can't reproduce this with gimp-2.8.2, do you
> still see this issue? Thanks.

I updated my system (to GIMP 2.8.2) and could not reproduce the problem anymore. What I do not know is whether this has been fixed on GIMP or on some library it depends on.
Comment 6 Nils Philippsen 2012-11-13 10:55:00 EST
Neither do I I'm afraid... I'll close this as WORKSFORME for now, please reopen if you get this error again.
Comment 7 Rob 2013-03-26 18:39:42 EDT
reported by another user in 2013 as bug 892828
	

Still exists.

Note You need to log in before you can comment on or make changes to this bug.