Bug 892828 - [abrt] gimp-2.8.2-6.fc18: gimp_tag_get_name: Process /usr/bin/gimp-2.8 was killed by signal 11 (SIGSEGV)
Summary: [abrt] gimp-2.8.2-6.fc18: gimp_tag_get_name: Process /usr/bin/gimp-2.8 was ki...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c3cd0ab3a45fdca4746eea8024a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-07 23:17 UTC by Reinhard
Modified: 2013-06-14 02:31 UTC (History)
3 users (show)

Fixed In Version: gimp-2.8.4-5.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-22 03:19:48 UTC


Attachments (Terms of Use)
File: backtrace (44.89 KB, text/plain)
2013-01-07 23:17 UTC, Reinhard
no flags Details
File: build_ids (10.33 KB, text/plain)
2013-01-07 23:17 UTC, Reinhard
no flags Details
File: cgroup (131 bytes, text/plain)
2013-01-07 23:17 UTC, Reinhard
no flags Details
File: core_backtrace (2.48 KB, text/plain)
2013-01-07 23:17 UTC, Reinhard
no flags Details
File: dso_list (24.47 KB, text/plain)
2013-01-07 23:17 UTC, Reinhard
no flags Details
File: environ (1.59 KB, text/plain)
2013-01-07 23:17 UTC, Reinhard
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-07 23:17 UTC, Reinhard
no flags Details
File: maps (135.25 KB, text/plain)
2013-01-07 23:18 UTC, Reinhard
no flags Details
File: open_fds (378 bytes, text/plain)
2013-01-07 23:18 UTC, Reinhard
no flags Details
File: proc_pid_status (922 bytes, text/plain)
2013-01-07 23:18 UTC, Reinhard
no flags Details
File: var_log_messages (313 bytes, text/plain)
2013-01-07 23:18 UTC, Reinhard
no flags Details

Description Reinhard 2013-01-07 23:17:36 UTC
Description of problem:
Playing around with brushes, creating new ones, deleting those, modifiying
not yet reproducable

Version-Release number of selected component:
gimp-2.8.2-6.fc18

Additional info:
backtrace_rating: 4
cmdline:        gimp-2.8 '/home/reinhard/Bilder/2013/2013-01 Gnadenkirche/DSC00014.JPG'
crash_function: gimp_tag_get_name
executable:     /usr/bin/gimp-2.8
kernel:         3.6.11-3.fc18.x86_64
remote_result:  844014
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gimp_tag_get_name at gimptag.c:184
 #1 gimp_tag_popup_list_expose at gimptagpopup.c:755
 #2 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c:86
 #7 gtk_widget_event_internal at gtkwidget.c:5017
 #8 gtk_widget_send_expose at gtkwidget.c:4846
 #9 gtk_main_do_event at gtkmain.c:1610
 #10 _gdk_window_process_updates_recurse at gdkwindow.c:5429
 #12 _gdk_windowing_window_process_updates_recurse at gdkwindow-x11.c:5643
 #13 gdk_window_process_updates_internal at gdkwindow.c:5588
 #14 gdk_window_process_all_updates at gdkwindow.c:5696

Potential duplicate: bug 847273

Comment 1 Reinhard 2013-01-07 23:17:39 UTC
Created attachment 674427 [details]
File: backtrace

Comment 2 Reinhard 2013-01-07 23:17:42 UTC
Created attachment 674428 [details]
File: build_ids

Comment 3 Reinhard 2013-01-07 23:17:44 UTC
Created attachment 674429 [details]
File: cgroup

Comment 4 Reinhard 2013-01-07 23:17:46 UTC
Created attachment 674430 [details]
File: core_backtrace

Comment 5 Reinhard 2013-01-07 23:17:49 UTC
Created attachment 674431 [details]
File: dso_list

Comment 6 Reinhard 2013-01-07 23:17:56 UTC
Created attachment 674432 [details]
File: environ

Comment 7 Reinhard 2013-01-07 23:17:58 UTC
Created attachment 674433 [details]
File: limits

Comment 8 Reinhard 2013-01-07 23:18:01 UTC
Created attachment 674434 [details]
File: maps

Comment 9 Reinhard 2013-01-07 23:18:03 UTC
Created attachment 674435 [details]
File: open_fds

Comment 10 Reinhard 2013-01-07 23:18:05 UTC
Created attachment 674436 [details]
File: proc_pid_status

Comment 11 Reinhard 2013-01-07 23:18:07 UTC
Created attachment 674437 [details]
File: var_log_messages

Comment 12 Rob 2013-03-26 22:36:50 UTC
yep.  Still exists in 2.8.4.


#0  0x00007fbecbbe0466 in gimp_tag_get_name (tag=0x7fbecdefe640) at gimptag.c:184
184       g_return_val_if_fail (GIMP_IS_TAG (tag), NULL);
(gdb) bt
#0  0x00007fbecbbe0466 in gimp_tag_get_name (tag=0x7fbecdefe640) at gimptag.c:184
#1  0x00007fbecbab9289 in gimp_tag_popup_list_expose (widget=widget@entry=0x7fbedb48e590 [GtkDrawingArea], event=
    0x7ffff14a04b0, popup=popup@entry=0x7fbecf5b64c0 [GimpTagPopup]) at gimptagpopup.c:755
#2  0x00007fbecadf1a1c in _gtk_marshal_BOOLEAN__BOXED (closure=0x7fbed71f2fb0, return_value=0x7ffff14a0010, 
    n_param_values=<optimized out>, param_values=0x7ffff14a00c0, invocation_hint=<optimized out>, 
    marshal_data=<optimized out>) at gtkmarshalers.c:86
#3  0x00007fbec7592664 in g_closure_invoke (closure=0x7fbed71f2fb0, return_value=return_value@entry=0x7ffff14a0010, 
    n_param_values=2, param_values=param_values@entry=0x7ffff14a00c0, invocation_hint=invocation_hint@entry=0x7ffff14a0060)
    at gclosure.c:777
#4  0x00007fbec75a36d8 in signal_emit_unlocked_R (node=node@entry=0x7fbecdca41f0, detail=detail@entry=0, 
    instance=instance@entry=0x7fbedb48e590, emission_return=emission_return@entry=0x7ffff14a0190, 
    instance_and_params=instance_and_params@entry=0x7ffff14a00c0) at gsignal.c:3551
#5  0x00007fbec75ab2a7 in g_signal_emit_valist (instance=0x7fbedb48e590, signal_id=<optimized out>, detail=0, 
    var_args=var_args@entry=0x7ffff14a0318) at gsignal.c:3310
#6  0x00007fbec75ab7c2 in g_signal_emit (instance=instance@entry=0x7fbedb48e590, signal_id=<optimized out>, 
    detail=detail@entry=0) at gsignal.c:3356
#7  0x00007fbecaf2548e in gtk_widget_event_internal (widget=widget@entry=0x7fbedb48e590 [GtkDrawingArea], event=event@entry=
    0x7ffff14a04b0) at gtkwidget.c:5017
#8  0x00007fbecaf25751 in IA__gtk_widget_send_expose (widget=widget@entry=0x7fbedb48e590 [GtkDrawingArea], 
    event=event@entry=0x7ffff14a04b0) at gtkwidget.c:4846
#9  0x00007fbecadefe60 in IA__gtk_main_do_event (event=0x7ffff14a04b0) at gtkmain.c:1610
#10 0x00007fbecaa2a54c in _gdk_window_process_updates_recurse (window=window@entry=0x7fbedb106b40 [GdkWindow], 
    expose_region=expose_region@entry=0x7fbecdefe640) at gdkwindow.c:5429
#11 0x00007fbecaa2a4f3 in _gdk_window_process_updates_recurse (window=window@entry=0x7fbedb106c60 [GdkWindow], 
    expose_region=expose_region@entry=0x7fbed1b7d490) at gdkwindow.c:5402
#12 0x00007fbecaa62515 in _gdk_windowing_window_process_updates_recurse (window=window@entry=0x7fbedb106c60 [GdkWindow], 
    region=region@entry=0x7fbed1b7d490) at gdkwindow-x11.c:5643
#13 0x00007fbecaa250c7 in gdk_window_process_updates_internal (window=0x7fbedb106c60 [GdkWindow]) at gdkwindow.c:5588
#14 0x00007fbecaa27448 in IA__gdk_window_process_all_updates () at gdkwindow.c:5696
#15 0x00007fbecaa274a9 in gdk_window_update_idle (data=<optimized out>) at gdkwindow.c:5322
#16 0x00007fbecaa03b97 in gdk_threads_dispatch (data=0x7fbed31e40e0) at gdk.c:512
#17 0x00007fbec6ea0825 in g_main_dispatch (context=0x7fbecdc3e2e0) at gmain.c:2539
#18 g_main_context_dispatch (context=context@entry=0x7fbecdc3e2e0) at gmain.c:3075
#19 0x00007fbec6ea0b58 in g_main_context_iterate (context=0x7fbecdc3e2e0, block=block@entry=1, dispatch=dispatch@entry=1, 
    self=<optimized out>) at gmain.c:3146
#20 0x00007fbec6ea0f52 in g_main_loop_run (loop=0x7fbed0bdcb70) at gmain.c:3340
#21 0x00007fbecb92b3c8 in app_run (full_prog_name=<optimized out>, filenames=<optimized out>, alternate_system_gimprc=0x0, 
    alternate_gimprc=0x0, session_name=<optimized out>, batch_interpreter=0x0, batch_commands=0x0, as_new=0, no_interface=
    0, no_data=0, no_fonts=0, no_splash=0, be_verbose=0, use_shm=1, use_cpu_accel=1, console_messages=0, use_debug_handler=
    0, stack_trace_mode=GIMP_STACK_TRACE_NEVER, pdb_compat_mode=GIMP_PDB_COMPAT_ON) at app.c:256
#22 0x00007fbecb92ae76 in main (argc=1, argv=0x7ffff14a09f8) at main.c:440
(gdb) q

Comment 13 Luke Suchocki 2013-04-06 21:56:47 UTC
My SEGV was listed as a duplicate of 847273 (WORKSFORME) and then the last comment shows it was reported in this bug.

gimp-2.8.4-1.fc17

Selecting and de-selecting brush tags within "Layers - Brushes" window, under the brushes list.
After selecting "basic, legacy, media" and then attempting to de-select one of "media" or "legacy", SEGV.

I WAS able to duplicate this after selecting the pixel brush and click a bunch of tags, selecting and de-selecting..

Eventually will SEGV after a few times.

Do not need to have any projects / images open.

Comment 14 Nils Philippsen 2013-04-08 15:19:07 UTC
Luke: thanks for describing how to reproduce this issue, I managed to do that following this.

Comment 15 Nils Philippsen 2013-04-20 12:46:09 UTC
I've fixed this upstream in master and gimp-2-8. I'm currently building 2.8.4-3 for F-17..19, Rawhide and will submit an update shortly.

Comment 16 Nils Philippsen 2013-04-20 13:21:09 UTC
Unfortunately the package doesn't build on F-17 right now :-(.

Comment 17 Fedora Update System 2013-04-20 13:22:53 UTC
gimp-2.8.4-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gimp-2.8.4-3.fc19

Comment 18 Fedora Update System 2013-04-20 13:23:04 UTC
gimp-2.8.4-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gimp-2.8.4-3.fc18

Comment 19 Fedora Update System 2013-04-21 03:23:32 UTC
Package gimp-2.8.4-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gimp-2.8.4-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6168/gimp-2.8.4-3.fc18
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2013-05-22 03:19:48 UTC
gimp-2.8.4-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-06-04 10:15:53 UTC
gimp-2.8.4-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gimp-2.8.4-5.fc17

Comment 22 Fedora Update System 2013-06-14 02:31:44 UTC
gimp-2.8.4-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.