Bug 847424 - rhc tools reports failure for creating scaled java app but it succeeds
rhc tools reports failure for creating scaled java app but it succeeds
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
1.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Matt Woodson
libra bugs
: Triaged
: 849313 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 23:14 EDT by Wesley Hearn
Modified: 2012-08-23 16:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 16:38:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Hearn 2012-08-10 23:14:45 EDT
Description of problem:
When creating a scalable jbossas-7 app the rhc command line tools reports failure

Version-Release number of selected component (if applicable):
rubygem-rhc-0.95.14-2.fc17.noarch

How reproducible:
Always

Steps to Reproduce:
1. export pass="your openshift password"
2. rhc-create-app -a testscale1 -t jbosseap-6.0 -p $pass -s -d
3. watch error
  
Actual results:
Submitting form:
rhlogin: whearn@redhat.com
debug: true
Contacting https://openshift.redhat.com
Creating application: testscale1 in whearn
Problem reported from server. Response code was .

MESSAGES:
Failed to access resource: 


Expected results:
It to succeed and check out the git repository.


Additional info:
Comment 1 Wesley Hearn 2012-08-10 23:17:24 EDT
Forgot to post the success line from user_action.log:
SUCCESS DATE=2012-08-10 TIME=22:31:48 ACTION=ADD_APPLICATION REQ_ID=e6c5c77932bb4467af2f81af5d8085a9 USER_ID=da8d582bbfc6480bafea382caf466f69 LOGIN=whearn@redhat.com Created application testscale1
Comment 2 Rob Millner 2012-08-14 13:12:45 EDT
This is likely timeout based - JbossAS7 is the most time consuming cartridge to configure.
Comment 3 N. Harrison Ripps 2012-08-22 16:10:48 EDT
*** Bug 849313 has been marked as a duplicate of this bug. ***
Comment 4 N. Harrison Ripps 2012-08-22 16:21:36 EDT
Worked on this with Rajat. We were able to reproduce this using a direct request against the production broker using a curl command. This suggested that the problem was not in the rhc client tools.

Rajat and Ram ran with this and found the source of the problem: we are using Amazon's Elastic Load Balancer (ELB) with our production broker, and ELB has a 60-second timeout: https://forums.aws.amazon.com/thread.jspa?threadID=33427&start=50&tstart=50

In the long term, the broker and rhc client tools should be modified to handle the app creation process with multiple discrete actions:

1. User uses rhc client tools to request a new app
2. Broker responds with a ticket and kicks off the app creation
3. User can 'check in' with the ticket to monitor app creation progress
4. When the app is ready, user can use the ticket to set up the git clone

(User stories to this effect already exist in our backlog)

This approach makes an issue like a 60-second timeout unimportant to the implementation, and will ensure that the process works for ever-larger app setups.

In the meantime, we need to find another way to work around ELB's 60-second limit.
Comment 5 N. Harrison Ripps 2012-08-22 16:28:09 EDT
Reclassified and assigned to twoodson.
Comment 6 N. Harrison Ripps 2012-08-22 16:28:46 EDT
(In reply to comment #5)
> Reclassified and assigned to twoodson.

sorry; that's mwoodson.
Comment 7 Matt Woodson 2012-08-23 09:29:29 EDT
I have disabled the AWS ELB.  openshift.redhat.com is now round robin between our two proxy nodes. 

This will fix the ELB timeout problem.
Comment 8 Adam Miller 2012-08-23 16:38:13 EDT
As per our end of print scrum, marking this fixed. Closing.

Note You need to log in before you can comment on or make changes to this bug.