Bug 847626 - [FEAT] nfsv3 cluster aware rpc.statd for NLM failover
[FEAT] nfsv3 cluster aware rpc.statd for NLM failover
Status: CLOSED DUPLICATE of bug 1188184
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All Linux
low Severity low
: ---
: ---
Assigned To: bugs@gluster.org
: FutureFeature, Triaged
Depends On:
Blocks: 854182
  Show dependency treegraph
 
Reported: 2012-08-13 03:40 EDT by Krishna Srinivas
Modified: 2015-02-27 04:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-27 04:57:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Krishna Srinivas 2012-08-13 03:40:20 EDT
As of now there is no support for glusterfs NLM failover as the new server to which it fails over does not know which clients were previously accessing the failed server to send NSM notifications to. We need to figure out how we can fix this behavior.
Comment 2 Niels de Vos 2015-02-27 04:57:11 EST
This is not reasonably solvable within Gluster/NFS. However, the move to NFS-Ganesha with HA through pacemaker/corosync includes this feature.

http://www.gluster.org/community/documentation/index.php/Features/HA_for_ganesha

*** This bug has been marked as a duplicate of bug 1188184 ***

Note You need to log in before you can comment on or make changes to this bug.