Bug 847701 - timeouts on shutdown stopping LUKS device units
timeouts on shutdown stopping LUKS device units
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 05:59 EDT by htd
Modified: 2012-09-14 05:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 857406 (view as bug list)
Environment:
Last Closed: 2012-09-14 05:28:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log on shutdown (532.10 KB, image/jpeg)
2012-08-13 05:59 EDT, htd
no flags Details
Fstab (1.04 KB, text/plain)
2012-08-16 06:00 EDT, htd
no flags Details
Crypttab (270 bytes, text/plain)
2012-08-16 06:01 EDT, htd
no flags Details

  None (edit)
Description htd 2012-08-13 05:59:12 EDT
Created attachment 603944 [details]
Log on shutdown

Description of problem:
Shutting down takes several minutes.

Version-Release number of selected component (if applicable):
systemd-sysv-44-17.fc17.x86_64
systemd-44-17.fc17.x86_64

How reproducible:
Problem occurs on shutting down from XFCE graphical env., in ca. 75% of all cases.

Steps to Reproduce:
1. shutdown
2.
3.
  
Actual results:
Shutdown is delayed 2-3 minutes with several "time outs". See attached picture.

Expected results:
Machine shuts down in acceptable time.

Additional info:
See attached picture for what shows up on the screen. First it hangs ~ 2 min after the first two lines, and ca. 2 minutes again where the lines on the pictures end.
Comment 1 htd 2012-08-13 13:55:47 EDT
Switching to runlevel 3 and shutting down via "shutdown -h now" works without any delay, as expected.
Comment 2 htd 2012-08-16 04:59:52 EDT
Btw, here's an identical report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679114

Tried "TimeoutSec=3" without any success.
Comment 3 Michal Schmidt 2012-08-16 05:39:47 EDT
Please attach /etc/fstab and /etc/crypttab.
Comment 4 htd 2012-08-16 06:00:08 EDT
Created attachment 604870 [details]
Fstab
Comment 5 htd 2012-08-16 06:01:49 EDT
Created attachment 604873 [details]
Crypttab
Comment 6 htd 2012-08-18 06:30:52 EDT
After reading a lot, trying a lot and installing a fresh fully encryted F17 on another machine, I give up. And I have to take back that booting into runlevel 3 and "shutdown -h now" helps; it doesn't. With a 2:3 chance, my systems hang on shutdown for several minutes, as shown on the attached picture. I tried all I could come over and to, without success. 

Since this is a "business" machine I'm using for my mastergrade studies, it's simply unacceptable to have to wait this long when shutting down.I'm travelling a lot, and to leave the harddisk unencrypted is no option either, especially because this problem was not present in F15/F16.

So if somebody has a fix or a workaround I'd be very thankful!

In the meantime, I'm forced to install another distribution (Arch) on my main machine and get things copied over, before the weekend is gone, to get rid of this. I'll keep one of the machines untouched, in case I can help to explore/fix this bug (which I'm more than willing to).
Comment 7 htd 2012-09-01 13:46:45 EDT
Now, after nearly 3 weeks since I reported this bug without a single useful reply, there's only one Fedora machine left, all the others run Arch now, which hasn't this annoying behaviour. So dear bug-maintainer/asignee, whoever you are - you can close this one. Since Arch works as expected, I do not care any longer. The last Fedora machine will be re-installed later this week.
Comment 8 Lennart Poettering 2012-09-14 05:27:47 EDT
OK, closing.

If you still want to help, we'd appreciate getting the output of dmesg of shutdown as explained here:

http://freedesktop.org/wiki/Software/systemd/Debugging#Diagnosing_Shutdown_Problems

If you attach that output, please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.