Bug 857406 - timeouts on shutdown stopping LUKS device units
timeouts on shutdown stopping LUKS device units
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 06:45 EDT by htd
Modified: 2013-08-01 07:24 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 847701
Environment:
Last Closed: 2013-08-01 07:24:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shutdown log as requested (323.00 KB, text/plain)
2012-09-14 06:45 EDT, htd
no flags Details

  None (edit)
Description htd 2012-09-14 06:45:50 EDT
Created attachment 612805 [details]
Shutdown log as requested

+++ This bug was initially created as a clone of Bug #847701 +++

Created attachment 603944 [details]
Log on shutdown

Description of problem:
Shutting down takes several minutes.

Version-Release number of selected component (if applicable):
systemd-sysv-44-17.fc17.x86_64
systemd-44-17.fc17.x86_64

How reproducible:
Problem occurs on shutting down from XFCE graphical env., in ca. 75% of all cases.

Steps to Reproduce:
1. shutdown
2.
3.
  
Actual results:
Shutdown is delayed 2-3 minutes with several "time outs". See attached picture.

Expected results:
Machine shuts down in acceptable time.

Additional info:
See attached picture for what shows up on the screen. First it hangs ~ 2 min after the first two lines, and ca. 2 minutes again where the lines on the pictures end.

--- Additional comment from htd@fritha.org on 2012-08-13 13:55:47 EDT ---

Switching to runlevel 3 and shutting down via "shutdown -h now" works without any delay, as expected.

--- Additional comment from htd@fritha.org on 2012-08-16 04:59:52 EDT ---

Btw, here's an identical report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679114

Tried "TimeoutSec=3" without any success.

--- Additional comment from mschmidt@redhat.com on 2012-08-16 05:39:47 EDT ---

Please attach /etc/fstab and /etc/crypttab.

--- Additional comment from htd@fritha.org on 2012-08-16 06:00:08 EDT ---

Created attachment 604870 [details]
Fstab

--- Additional comment from htd@fritha.org on 2012-08-16 06:01:49 EDT ---

Created attachment 604873 [details]
Crypttab

--- Additional comment from htd@fritha.org on 2012-08-18 06:30:52 EDT ---

After reading a lot, trying a lot and installing a fresh fully encryted F17 on another machine, I give up. And I have to take back that booting into runlevel 3 and "shutdown -h now" helps; it doesn't. With a 2:3 chance, my systems hang on shutdown for several minutes, as shown on the attached picture. I tried all I could come over and to, without success. 

Since this is a "business" machine I'm using for my mastergrade studies, it's simply unacceptable to have to wait this long when shutting down.I'm travelling a lot, and to leave the harddisk unencrypted is no option either, especially because this problem was not present in F15/F16.

So if somebody has a fix or a workaround I'd be very thankful!

In the meantime, I'm forced to install another distribution (Arch) on my main machine and get things copied over, before the weekend is gone, to get rid of this. I'll keep one of the machines untouched, in case I can help to explore/fix this bug (which I'm more than willing to).

--- Additional comment from htd@fritha.org on 2012-09-01 13:46:45 EDT ---

Now, after nearly 3 weeks since I reported this bug without a single useful reply, there's only one Fedora machine left, all the others run Arch now, which hasn't this annoying behaviour. So dear bug-maintainer/asignee, whoever you are - you can close this one. Since Arch works as expected, I do not care any longer. The last Fedora machine will be re-installed later this week.

--- Additional comment from lpoetter@redhat.com on 2012-09-14 05:27:47 EDT ---

OK, closing.

If you still want to help, we'd appreciate getting the output of dmesg of shutdown as explained here:

http://freedesktop.org/wiki/Software/systemd/Debugging#Diagnosing_Shutdown_Problems

If you attach that output, please reopen the bug.
Comment 1 Lennart Poettering 2012-09-14 09:29:26 EDT
Hmm, just reopening the bug would have sufficed.

Is this LUKS on LVm or something weird? Swap on LUKS? Swap on LVM?
Comment 2 htd 2012-09-14 09:47:10 EDT
Sorry, I couldn't find out how a bug is re-opened. This was the only way I came over.

The machine is a Laptop with 1 harddisk and 4 partitions. An unencrypted /boot, and LUKS/dmcrypt encrypted root, swap and home. No LVM or other magic. Simply 4 primary partitions.
Comment 3 htd 2012-09-19 10:21:07 EDT
First: I'm not a programmer in any way.
I recompiled systemd yesterday, after changing this line in def.h:

 #define DEFAULT_TIMEOUT_USEC (10*USEC_PER_SEC)

90 sec is the default, if I remember correctly. Changed it to 10, and this eases the pain quite a bit, the waiting thime after the timeout is now definitely shorter. The problem remains the same, however..
Comment 4 htd 2012-09-29 04:50:57 EDT
Any more comments on this one?

I reinstalled the machine with F17 solely to help you to debug this issue, and if there's no more further interest, I'd like to use the machine for something useful.
Comment 5 Fedora End Of Life 2013-07-03 23:34:54 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2013-08-01 07:24:51 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.