Bug 847706 - [abrt] slrn-0.9.9p1-5.fc17: __wmemcmp_ssse3: Process /usr/bin/slrn was killed by signal 11 (SIGSEGV)
[abrt] slrn-0.9.9p1-5.fc17: __wmemcmp_ssse3: Process /usr/bin/slrn was killed...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: slrn (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
abrt_hash:4c9cc96542456f2f5c61f815953...
:
: 773637 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 06:06 EDT by Vedran Krivokuca
Modified: 2013-01-18 15:51 EST (History)
2 users (show)

See Also:
Fixed In Version: slrn-1.0.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 15:42:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.47 KB, text/plain)
2012-08-13 06:06 EDT, Vedran Krivokuca
no flags Details
File: maps (8.97 KB, text/plain)
2012-08-13 06:06 EDT, Vedran Krivokuca
no flags Details
Fix ported from upstream (1.22 KB, patch)
2013-01-08 09:40 EST, Petr Pisar
no flags Details | Diff

  None (edit)
Description Vedran Krivokuca 2012-08-13 06:06:46 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/slrn
comment:        Tried to open a group for reading in SLRN.
crash_function: __wmemcmp_ssse3
executable:     /usr/bin/slrn
kernel:         3.5.1-1.fc17.x86_64
pid:            15477
pwd:            /home/vedran
remote_result:  773637
time:           Mon 13 Aug 2012 11:37:10 AM CEST
uid:            515
username:       vkrivoku

backtrace:      Text file, 29149 bytes
maps:           Text file, 9185 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/vkrivoku/2

core_backtrace:
:f69712fe393313f44607679e934bf5a67f39ec50 0x15f7f1 __strlen_sse2_pminub libc.so.6 -
:25d4098816967280defd6d67b3a238d5d69303b5 0x25b8a - [exe] -
:94beb2c8dc9fc5184fc0100dabfa3d28e6a38bab 0x7addc - libslang.so.2 -
:94beb2c8dc9fc5184fc0100dabfa3d28e6a38bab 0x7cd07 SLrline_set_display_width libslang.so.2 -
:25d4098816967280defd6d67b3a238d5d69303b5 0x25d17 - [exe] -
:25d4098816967280defd6d67b3a238d5d69303b5 0x27a3b - [exe] -
:25d4098816967280defd6d67b3a238d5d69303b5 0x1b401 - [exe] -
:25d4098816967280defd6d67b3a238d5d69303b5 0x1b5b9 - [exe] -
:25d4098816967280defd6d67b3a238d5d69303b5 0x66b8 - [exe] -

dso_list:
:/usr/lib64/libplc4.so nspr-4.9.1-2.fc17.x86_64 (Fedora Project) 1343488024
:/usr/lib64/libnssutil3.so nss-util-3.13.5-1.fc17.x86_64 (Fedora Project) 1343488031
:/usr/lib64/libnss_dns-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/libssl3.so nss-3.13.5-1.fc17.x86_64 (Fedora Project) 1343489292
:/usr/lib64/libz.so.1.2.5 zlib-1.2.5-6.fc17.x86_64 (Fedora Project) 1343488017
:/usr/lib64/libnss3.so nss-3.13.5-1.fc17.x86_64 (Fedora Project) 1343489292
:/usr/lib64/libm-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/gconv/gconv-modules.cache glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/libsmime3.so nss-3.13.5-1.fc17.x86_64 (Fedora Project) 1343489292
:/usr/lib64/libnss_files-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/libslang.so.2.2.4 slang-2.2.4-3.fc17.x86_64 (Fedora Project) 1343488114
:/usr/lib64/libdl-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/libnss_mdns4_minimal.so.2 nss-mdns-0.10-10.fc17.x86_64 (Fedora Project) 1343490235
:/usr/lib64/libpthread-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/bin/slrn slrn-0.9.9p1-5.fc17.x86_64 (Fedora Project) 1343492616
:/usr/lib64/libc-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/libnss_compat_ossl.so.0.0.0 nss_compat_ossl-0.9.6-3.fc17.x86_64 (Fedora Project) 1343489294
:/usr/lib64/libplds4.so nspr-4.9.1-2.fc17.x86_64 (Fedora Project) 1343488024
:/usr/lib/locale/locale-archive glibc-common-2.15-51.fc17.x86_64 (Fedora Project) 1343488008
:/usr/lib64/libnspr4.so nspr-4.9.1-2.fc17.x86_64 (Fedora Project) 1343488024
:/usr/lib64/gconv/ISO8859-2.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/libresolv-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012
:/usr/lib64/ld-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1343488012

environ:
:QT_GRAPHICSSYSTEM_CHECKED=1
:XDG_CONFIG_DIRS=/etc/xdg
:GLADE_CATALOG_PATH=:
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:XDG_VTNR=1
:PWD=/home/vedran
:LOGNAME=vkrivoku
:SHLVL=4
:GNOME_KEYRING_PID=1998
:CVS_RSH=ssh
:IMSETTINGS_MODULE=none
:XDG_SEAT=seat0
:QTLIB=/usr/lib64/qt-3.3/lib
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
:QTDIR=/usr/lib64/qt-3.3
:XAUTHORITY=/var/run/gdm/auth-for-vkrivoku-GdEWb7/database
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_SESSION_ID=2
:DISPLAY=:0.0
:DESKTOP_SESSION=xfce
:XDG_RUNTIME_DIR=/run/user/vkrivoku
:GDMSESSION=xfce
:GNOME_KEYRING_CONTROL=/run/user/vkrivoku/keyring-MaTeT5
:WINDOWPATH=1
:COLORTERM=Terminal
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-AD8ARFUQWK,guid=a8245e5e1893e0f88e398bb90000002b
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:MAIL=/var/spool/mail/vkrivoku
:_=/usr/bin/slrn
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:HISTCONTROL=ignoredups
:XDG_MENU_PREFIX=xfce-
:GLADE_MODULE_PATH=:
:XDG_SESSION_COOKIE=d023f47fe820502757c1016c00000016-1344843942.701291-1952183107
:SHELL=/bin/zsh
:HOSTNAME=kvedran
:LIBGLADE_MODULE_PATH=:
:QT_IM_MODULE=xim
:WINDOWID=65011716
:SSH_AGENT_PID=2151
:HISTSIZE=500000
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2194,unix/unix:/tmp/.ICE-unix/2194
:SSH_AUTH_SOCK=/tmp/ssh-uBDWDHmZ2002/agent.2002
:PATH=/home/vedran/zbin:/home/vedran/zbin/jsvn:/opt/asdk/tools:/opt/asdk/platform-tools:/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/home/vedran/bin:/usr/local/sbin:/usr/sbin
:TERM=xterm-256color
:USER=vkrivoku
:GLADE_PIXMAP_PATH=:
:XMODIFIERS=@im=none
:HOME=/home/vedran
:QTINC=/usr/lib64/qt-3.3/include
:GPG_AGENT_INFO=/home/vedran/.gnupg/S.gpg-agent:2185:1
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:OLDPWD=/home/vedran
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.htm=00;33:*.html=00;33:*.shtml=00;33:*.wpd=00;33:
:EDITOR=vim
:PYTHONPATH=/home/vedran/workspace/nimium-pytils/src
:NNTPSERVER=news.individual.net
:__GIT_PROMPT_DIR=/home/vedran/.zsh/git-prompt
:'HISTIGNORE=&:ls:[bf]g:exit:reset:clear:cd:cd ..:cd..'
:HISTFILE=/home/vedran/.zsh_history
:SAVEHIST=500000
:PAGER=less
:'LESS=-R -iMSx4 -FX'
:NNTP_SERVER=news.individual.net

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63315                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63315                63315                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/0
:pos:	0
:flags:	0100002
:1:/dev/pts/0
:pos:	0
:flags:	0100002
:2:/dev/pts/0
:pos:	0
:flags:	0100002
:3:socket:[111078]
:pos:	0
:flags:	02
:4:/dev/tty
:pos:	0
:flags:	02100002

var_log_messages:
:Aug 13 11:37:10 kvedran kernel: [ 6729.053766] slrn[15477]: segfault at 0 ip 0000003a6635f7f1 sp 00007fff87da4c58 error 4 in libc-2.15.so[3a66200000+1ac000]
:Aug 13 11:37:10 kvedran abrt[15515]: Saved core dump of pid 15477 (/usr/bin/slrn) to /var/spool/abrt/ccpp-2012-08-13-11:37:10-15477 (7417856 bytes)
Comment 1 Vedran Krivokuca 2012-08-13 06:06:53 EDT
Created attachment 603946 [details]
File: backtrace
Comment 2 Vedran Krivokuca 2012-08-13 06:06:57 EDT
Created attachment 603947 [details]
File: maps
Comment 3 Petr Pisar 2013-01-08 09:17:49 EST
This is NULL pointer dereference in readline call-backs. slang problably passes NULL string. It has been fixed by upstream commit:

commit 21fee1da0b829558d92fa1f7d7eceba22dbd5804
Author: John E. Davis <davis@space.mit.edu>
Date:   Mon Jul 25 15:49:02 2011 -0400

    slrn pre1.0.0 change 27: Avoid prompt==NULL deref in rline_update.
Comment 4 Petr Pisar 2013-01-08 09:40:50 EST
Created attachment 674873 [details]
Fix ported from upstream
Comment 5 Petr Pisar 2013-01-08 09:48:27 EST
*** Bug 773637 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-01-08 09:54:17 EST
slrn-1.0.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/slrn-1.0.1-1.fc18
Comment 7 Fedora Update System 2013-01-08 10:06:24 EST
slrn-0.9.9p1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/slrn-0.9.9p1-6.fc17
Comment 8 Fedora Update System 2013-01-08 10:06:43 EST
slrn-0.9.9p1-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/slrn-0.9.9p1-5.fc16
Comment 9 Fedora Update System 2013-01-08 15:16:04 EST
Package slrn-1.0.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing slrn-1.0.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0405/slrn-1.0.1-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-01-18 15:42:48 EST
slrn-1.0.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-01-18 15:44:25 EST
slrn-0.9.9p1-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-01-18 15:51:42 EST
slrn-0.9.9p1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.