Bug 847738 - When query.cgi?product=$PRODUCT is acessed, load component list for $PRODUCT directly
When query.cgi?product=$PRODUCT is acessed, load component list for $PRODUCT ...
Status: CLOSED DUPLICATE of bug 823339
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
medium Severity high (vote)
: ---
: ---
Assigned To: Simon Green
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 07:49 EDT by David Jaša
Modified: 2014-10-12 18:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 20:41:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-08-13 07:49:12 EDT
Description of problem:
When query.cgi?product=${PRODUCT} is acessed, load component list for PRODUCT directly. There are two problems with this approach:
1. this is b/w-inefficient expecially for smaller products (TCMS, oVirt, ...)
2. it triggers firefox lockup mentioned in bug 823339

Version-Release number of selected component (if applicable):
bugzilla 4.2 on bugzilla.redhat.com as of 2012/08/13

How reproducible:
always

Steps to Reproduce:
1. go to bugzilla.redhat.com/query.cgi?product=oVirt
2.
3.
  
Actual results:
1. page loads full component list across all classifications and products
2. the component list is narrowed down by javascript

Expected results:
component lists is narrowed down server-side

Additional info:
Marking as a regression because previous bugzilla didn't suffer from this issue
Comment 1 David Jaša 2012-08-13 08:06:42 EDT
(In reply to comment #0)
...
> There are two problems with this approach:
> 1. this is b/w-inefficient expecially for smaller products (TCMS, oVirt, ...)
> 2. it triggers firefox lockup mentioned in bug 823339

3. it breaks "back" button function which is heavily used in bugzilla in general
Comment 2 Simon Green 2012-08-13 20:41:28 EDT

*** This bug has been marked as a duplicate of bug 823339 ***

Note You need to log in before you can comment on or make changes to this bug.