Bug 847920 - The scalable app home page can't get back by hit app page if app is idled
The scalable app home page can't get back by hit app page if app is idled
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Triaged
: 847917 848138 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 22:42 EDT by Rony Gong
Modified: 2015-05-14 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:28:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/httpd/access_log (2.05 KB, text/plain)
2012-08-13 22:42 EDT, Rony Gong
no flags Details

  None (edit)
Description Rony Gong 2012-08-13 22:42:08 EDT
Description of problem:
The scalable app home page can't get back by hit app page if app is idled
like access: http://qsphp-qgong5.dev.rhcloud.com/

but could get back by access app gear page. like:
http://7c806abb41-qgong5.dev.rhcloud.com/

Version-Release number of selected component (if applicable):
devenv_1979


How reproducible:
always

Steps to Reproduce:
1.Create an scalable app
2.After a period of time(this will make app idler), then hit the app home page
3.
  
Actual results:
only show haproxy status


Expected results:
the app statue should become started, and hit the app home page, the app page should come back.

Additional info:
Since the idler mechanism is caused by 2 condition, one is check the commit time, another is check the access time in /var/log/httpd/access_log

And I could find the app gear(7c806abb41-qgong5) access log in above log after I just created a scalable app. so it will cause  both app gear and haproxy gear  idler.
Comment 1 Rony Gong 2012-08-13 22:42:56 EDT
Created attachment 604134 [details]
/var/log/httpd/access_log
Comment 2 Rony Gong 2012-08-13 22:53:13 EDT
*** Bug 847917 has been marked as a duplicate of this bug. ***
Comment 3 Bill DeCoste 2012-08-14 15:03:47 EDT
Workaround:

1. ssh into the app
2. Issue a wget directly to the app
3. app will be restored and accessible externally
Comment 4 Bill DeCoste 2012-08-14 15:04:22 EDT
*** Bug 848138 has been marked as a duplicate of this bug. ***
Comment 5 John Poelstra 2012-08-21 13:40:57 EDT
Bill is going to take another look, but believes that this is no longer a bug.
Comment 6 Bill DeCoste 2012-08-21 13:59:41 EDT
Moving to QA so they can start to verify. Unable to reproduce in dev - haproxy gear idles and restores properly. Waiting for app to idle in INT to confirm.
Comment 8 Rony Gong 2012-08-22 06:49:43 EDT
verified on denenv_2050, could wakeup by access app page

Note You need to log in before you can comment on or make changes to this bug.