Bug 848138 - Scaled apps are never restored once idle
Scaled apps are never restored once idle
Status: CLOSED DUPLICATE of bug 847920
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 14:09 EDT by Bill DeCoste
Modified: 2015-05-14 22:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 15:04:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill DeCoste 2012-08-14 14:09:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill DeCoste 2012-08-14 14:14:03 EDT
Description of problem:
When a scaled app goes idle, hitting the application from a browser does not restore the application. The result is the haproxt stats page only. An internal wget directly to the appl restores the app which then becomes accessible externally


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a scaled jbossas-7
2. Wait until the application goes idle
3. Hit the application URL - this will show the haproxy stats page

4. ssh into the app
5. Issue a wget directly to the app
6. app will be restored and accessible externally
  
Actual results:
happroxy stats page, idle app


Expected results:
restored app accessible externally


Additional info:
Comment 2 Dan McPherson 2012-08-14 14:58:39 EDT
Is this a dup of:  847920
Comment 3 Bill DeCoste 2012-08-14 15:02:28 EDT
Ya, looks like it. Ram asked me to open a new bug and assign to him. I'll close this and comment on the other one.
Comment 4 Bill DeCoste 2012-08-14 15:04:22 EDT

*** This bug has been marked as a duplicate of bug 847920 ***

Note You need to log in before you can comment on or make changes to this bug.